diff options
author | Jussi Kukkonen <jussi.kukkonen@intel.com> | 2016-05-16 16:22:50 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-05-17 21:18:44 +0100 |
commit | d972c6239eb0d7153940ebecb5e3301d51a33110 (patch) | |
tree | ddd3a93bbe1b870573c8075efd6db25cbc08a13d /meta/recipes-graphics/wayland/weston_1.10.0.bb | |
parent | aac99fb37faf71b9c14a9932b07c943e232323e8 (diff) | |
download | poky-d972c6239eb0d7153940ebecb5e3301d51a33110.tar.gz |
weston: Upgrade 1.9.0 -> 1.10.0
Support for multiple new protocols, many new features:
https://lists.freedesktop.org/archives/wayland-devel/2016-February/027039.html
* Weston now depends on wayland-protocols (which is protocol
collection split off from weston).
* Remove upstreamed patches, add a patch to fix the wayland-protocols
path used during build.
* Use HTTPS for tarball download
(From OE-Core rev: 9965dbeb89537be6ab97dc317b629fb24e5e6bbb)
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.10.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.10.0.bb | 104 |
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.10.0.bb b/meta/recipes-graphics/wayland/weston_1.10.0.bb new file mode 100644 index 0000000000..d8c9f9f696 --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_1.10.0.bb | |||
@@ -0,0 +1,104 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ | ||
6 | file://src/compositor.c;endline=23;md5=1d535fed266cf39f6d8c0647f52ac331" | ||
7 | |||
8 | SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop \ | ||
11 | file://make-libwebp-explicitly-configurable.patch \ | ||
12 | file://0001-make-error-portable.patch \ | ||
13 | file://0001-configure.ac-Fix-wayland-protocols-path.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "1cd17c54ecac6d9a3cd90bf12eaa3e20" | ||
16 | SRC_URI[sha256sum] = "e0b2004d00d8293ddf7903ca283c1746afa9ccb5919ab50fd04397ff472aa5c1" | ||
17 | |||
18 | inherit autotools pkgconfig useradd distro_features_check | ||
19 | # depends on virtual/egl | ||
20 | REQUIRED_DISTRO_FEATURES = "opengl" | ||
21 | |||
22 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
23 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | ||
24 | |||
25 | EXTRA_OECONF = "--enable-setuid-install \ | ||
26 | --enable-simple-clients \ | ||
27 | --enable-clients \ | ||
28 | --enable-demo-clients-install \ | ||
29 | --disable-rpi-compositor \ | ||
30 | --disable-rdp-compositor \ | ||
31 | WAYLAND_PROTOCOLS_SYSROOT_DIR=${STAGING_DIR}/${MACHINE} \ | ||
32 | " | ||
33 | EXTRA_OECONF[vardepsexclude] = "MACHINE" | ||
34 | |||
35 | EXTRA_OECONF_append_qemux86 = "\ | ||
36 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
37 | " | ||
38 | EXTRA_OECONF_append_qemux86-64 = "\ | ||
39 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
40 | " | ||
41 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ | ||
42 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
43 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \ | ||
44 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ | ||
45 | " | ||
46 | # | ||
47 | # Compositor choices | ||
48 | # | ||
49 | # Weston on KMS | ||
50 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev" | ||
51 | # Weston on Wayland (nested Weston) | ||
52 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa" | ||
53 | # Weston on X11 | ||
54 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
55 | # Headless Weston | ||
56 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
57 | # Weston on framebuffer | ||
58 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
59 | # weston-launch | ||
60 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam drm" | ||
61 | # VA-API desktop recorder | ||
62 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
63 | # Weston with EGL support | ||
64 | PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl" | ||
65 | # Weston with cairo glesv2 support | ||
66 | PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo" | ||
67 | # Weston with lcms support | ||
68 | PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms" | ||
69 | # Weston with webp support | ||
70 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp" | ||
71 | # Weston with unwinding support | ||
72 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" | ||
73 | # Weston with systemd-login support | ||
74 | PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus" | ||
75 | # Weston with Xwayland support | ||
76 | PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland,libxcb libxcursor cairo" | ||
77 | # colord CMS support | ||
78 | PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord" | ||
79 | |||
80 | do_install_append() { | ||
81 | # Weston doesn't need the .la files to load modules, so wipe them | ||
82 | rm -f ${D}/${libdir}/weston/*.la | ||
83 | |||
84 | # If X11, ship a desktop file to launch it | ||
85 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then | ||
86 | install -d ${D}${datadir}/applications | ||
87 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
88 | |||
89 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
90 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
91 | fi | ||
92 | } | ||
93 | |||
94 | PACKAGES += "${PN}-examples" | ||
95 | |||
96 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}" | ||
97 | FILES_${PN}-examples = "${bindir}/*" | ||
98 | |||
99 | RDEPENDS_${PN} += "xkeyboard-config" | ||
100 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
101 | RRECOMMENDS_${PN}-dev += "wayland-protocols" | ||
102 | |||
103 | USERADD_PACKAGES = "${PN}" | ||
104 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||