diff options
author | Ross Burton <ross.burton@intel.com> | 2013-05-31 15:57:35 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-06-07 16:48:26 +0100 |
commit | 2a739ad148d8a6ea531488e8495877d84acd5c12 (patch) | |
tree | 385791f2a82584b43700ff735297eb50df555afa /meta/recipes-graphics/wayland/weston_1.1.0.bb | |
parent | 74351853dcb2b42bc517318da5c7a437b1ea5bdb (diff) | |
download | poky-2a739ad148d8a6ea531488e8495877d84acd5c12.tar.gz |
weston: update to 1.1.0
Upgrade to 1.1.0, and disable the RaspberryPi and RDP compositors. Hopefully
the RPi community can send a patch to add a PACKAGECONFIG for them.
(From OE-Core rev: 2e8e31a6812368688138b53c0aa92982354f832f)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.1.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.1.0.bb | 79 |
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.1.0.bb b/meta/recipes-graphics/wayland/weston_1.1.0.bb new file mode 100644 index 0000000000..026f13666b --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_1.1.0.bb | |||
@@ -0,0 +1,79 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \ | ||
6 | file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c" | ||
7 | |||
8 | SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://install-examples.patch \ | ||
10 | file://weston.png \ | ||
11 | file://weston.desktop" | ||
12 | SRC_URI[md5sum] = "dd9f3043fc5228c6bc4e99873fae2254" | ||
13 | SRC_URI[sha256sum] = "e7715d2c731f77a729c994a599ffdaebac1307b2dd9336136706869fa53618b4" | ||
14 | |||
15 | |||
16 | inherit autotools pkgconfig useradd | ||
17 | |||
18 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 mtdev jpeg" | ||
19 | DEPENDS += "wayland mesa virtual/egl" | ||
20 | |||
21 | EXTRA_OECONF = "--disable-android-compositor \ | ||
22 | --enable-setuid-install \ | ||
23 | --disable-tablet-shell \ | ||
24 | --disable-xwayland \ | ||
25 | --enable-simple-clients \ | ||
26 | --enable-clients \ | ||
27 | --disable-simple-egl-clients \ | ||
28 | --disable-libunwind \ | ||
29 | --disable-rpi-compositor \ | ||
30 | --disable-rdp-compositor" | ||
31 | |||
32 | |||
33 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms wayland', '', d)} \ | ||
34 | ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
35 | ${@base_contains('DISTRO_FEATURES', 'opengles2', 'gles', '', d)} \ | ||
36 | " | ||
37 | # | ||
38 | # Compositor choices | ||
39 | # | ||
40 | # Weston on KMS | ||
41 | PACKAGECONFIG[kms] = "--enable-drm-compositor --enable-weston-launch,--disable-drm-compositor --disable-weston-launch,drm udev mesa libpam" | ||
42 | # Weston on Wayland (nested Weston) | ||
43 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,mesa" | ||
44 | # Weston on X11 | ||
45 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
46 | # Headless Weston | ||
47 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
48 | # Weston on framebuffer | ||
49 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
50 | |||
51 | # Use cairo-gl or cairo-glesv2 | ||
52 | PACKAGECONFIG[gles] = "--with-cairo-glesv2,,virtual/libgles2" | ||
53 | |||
54 | do_install_append() { | ||
55 | # Weston doesn't need the .la files to load modules, so wipe them | ||
56 | rm -f ${D}/${libdir}/weston/*.la | ||
57 | |||
58 | for feature in ${DISTRO_FEATURES}; do | ||
59 | # If X11, ship a desktop file to launch it | ||
60 | if [ "$feature" = "x11" ]; then | ||
61 | install -d ${D}${datadir}/applications | ||
62 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
63 | |||
64 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
65 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
66 | fi | ||
67 | done | ||
68 | } | ||
69 | |||
70 | PACKAGES += "${PN}-examples" | ||
71 | |||
72 | FILES_${PN} = "${bindir}/weston* ${bindir}/wcap-decode ${libexecdir} ${datadir}" | ||
73 | FILES_${PN}-examples = "${bindir}/*" | ||
74 | |||
75 | RDEPENDS_${PN} += "xkeyboard-config" | ||
76 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
77 | |||
78 | USERADD_PACKAGES = "${PN}" | ||
79 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||