summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston_1.0.6.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-03-27 17:53:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-29 10:40:55 +0000
commit53beaa604a965588f6455cd1981ed3a84662a4ff (patch)
tree56c025cbce440c1df7fb864416aa4ec978078bd4 /meta/recipes-graphics/wayland/weston_1.0.6.bb
parent9a3fbf92c4af93cdb66d515c3cd3e64610fbee4a (diff)
downloadpoky-53beaa604a965588f6455cd1981ed3a84662a4ff.tar.gz
weston: upgrade to 1.0.6
(From OE-Core rev: 58924fe567963c0e6cead3e75a2cfd5b2252aefd) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.0.6.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston_1.0.6.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.0.6.bb b/meta/recipes-graphics/wayland/weston_1.0.6.bb
new file mode 100644
index 0000000000..cb41e05c46
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston_1.0.6.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \
6 file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c"
7
8SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://weston.png \
10 file://weston.desktop"
11SRC_URI[md5sum] = "63202129d66d5514e572814da5dfa1f7"
12SRC_URI[sha256sum] = "c833bc4dc8667561d2639b57220541531c039aa9332ce2a7022a3c466eb894f1"
13
14inherit autotools pkgconfig
15
16DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 mtdev jpeg"
17DEPENDS += "wayland mesa virtual/egl"
18
19EXTRA_OECONF = "--disable-android-compositor --enable-setuid-install"
20EXTRA_OECONF += "--disable-tablet-shell --disable-xwayland"
21EXTRA_OECONF += "--enable-simple-clients --enable-clients --disable-simple-egl-clients"
22
23PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms wayland', '', d)} \
24 ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
25 ${@base_contains('DISTRO_FEATURES', 'opengles2', 'gles', '', d)} \
26 "
27# Weston on KMS
28PACKAGECONFIG[kms] = "--enable-drm-compositor --enable-weston-launch,--disable-drm-compositor --disable-weston-launch,drm udev mesa libpam"
29# Weston on Wayland (nested Weston)
30PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,mesa"
31# Weston on X11
32PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
33
34PACKAGECONFIG[gles] = "--with-cairo-glesv2,,virtual/libgles2"
35
36do_install_append() {
37 # Weston doesn't need the .la files to load modules, so wipe them
38 rm -f ${D}/${libdir}/weston/*.la
39
40 for feature in ${DISTRO_FEATURES}; do
41 # If X11, ship a desktop file to launch it
42 if [ "$feature" = "x11" ]; then
43 install -d ${D}${datadir}/applications
44 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
45
46 install -d ${D}${datadir}/icons/hicolor/48x48/apps
47 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
48 fi
49 done
50}
51
52FILES_${PN} += "${datadir}/applications ${datadir}/icons"
53
54RDEPENDS_${PN} += "xkeyboard-config"
55RRECOMMENDS_${PN} = "liberation-fonts"