summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-09-09 09:27:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-10 13:48:27 +0100
commit31259e5913ddd4962c0086f70639a7bd4da961cc (patch)
treee09b222fd4568415d88925cc4c59a832d654ecc9 /meta/recipes-graphics/wayland/weston-init.bb
parent75e803a4d043d053f181f2683945e418b294dad2 (diff)
downloadpoky-31259e5913ddd4962c0086f70639a7bd4da961cc.tar.gz
weston-init: Redefine weston service and add socket activation option
Currently, weston when autolauched with systemd ends up with seat0 related errors because its launched before seat0 is assigned. Fixes [05:16:09.357] logind: failed to get session seat [05:16:09.358] logind: cannot setup systemd-logind helper (-61), using legacy fallback The above error results in ptest failures in parselogs, even though weston has started ok using fallback methods, these errors are still seen in logs Also fixes weston ptests RESULTS - weston.WestonTest.test_weston_can_initialize_new_wayland_compositor: PASSED (8.58s) (From OE-Core rev: c21fa5a291ab207a084285935ab73a0b4225c965) Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Marek Vasut <marex@denx.de> Cc: Henning Heinold <henning@itconsulting-heinold.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 40aa76295f..95d75556dc 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -8,7 +8,9 @@ SRC_URI = "file://init \
8 file://weston.env \ 8 file://weston.env \
9 file://weston.ini \ 9 file://weston.ini \
10 file://weston@.service \ 10 file://weston@.service \
11 file://weston@.socket \
11 file://71-weston-drm.rules \ 12 file://71-weston-drm.rules \
13 file://weston-autologin \
12 file://weston-start" 14 file://weston-start"
13 15
14S = "${WORKDIR}" 16S = "${WORKDIR}"
@@ -20,6 +22,10 @@ do_install() {
20 22
21 # Install Weston systemd service and accompanying udev rule 23 # Install Weston systemd service and accompanying udev rule
22 install -D -p -m0644 ${WORKDIR}/weston@.service ${D}${systemd_system_unitdir}/weston@.service 24 install -D -p -m0644 ${WORKDIR}/weston@.service ${D}${systemd_system_unitdir}/weston@.service
25 install -D -p -m0644 ${WORKDIR}/weston@.socket ${D}${systemd_system_unitdir}/weston@.socket
26 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
27 install -D -p -m0644 ${WORKDIR}/weston-autologin ${D}${sysconfdir}/pam.d/weston-autologin
28 fi
23 sed -i -e s:/etc:${sysconfdir}:g \ 29 sed -i -e s:/etc:${sysconfdir}:g \
24 -e s:/usr/bin:${bindir}:g \ 30 -e s:/usr/bin:${bindir}:g \
25 -e s:/var:${localstatedir}:g \ 31 -e s:/var:${localstatedir}:g \
@@ -50,7 +56,7 @@ RDEPENDS_${PN} = "weston kbd"
50INITSCRIPT_NAME = "weston" 56INITSCRIPT_NAME = "weston"
51INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ." 57INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
52 58
53FILES_${PN} += "${sysconfdir}/xdg/weston/weston.ini ${systemd_system_unitdir}/weston@.service ${sysconfdir}/default/weston" 59FILES_${PN} += "${sysconfdir}/xdg/weston/weston.ini ${systemd_system_unitdir}/weston@.service ${systemd_system_unitdir}/weston@.socket ${sysconfdir}/default/weston ${sysconfdir}/pam.d/"
54 60
55CONFFILES_${PN} += "${sysconfdir}/xdg/weston/weston.ini ${sysconfdir}/default/weston" 61CONFFILES_${PN} += "${sysconfdir}/xdg/weston/weston.ini ${sysconfdir}/default/weston"
56 62