summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-09-12 14:04:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-14 00:14:28 +0100
commit30ed002d21a0f3dd851c0e6badfc526c77ad4a58 (patch)
treec7292e7e7755e1ff2817bb47a4cbe78f5eb80ff8 /meta/recipes-graphics/wayland/weston-init.bb
parent602066af708cfe3361d57c91e41c4a4337645ce0 (diff)
downloadpoky-30ed002d21a0f3dd851c0e6badfc526c77ad4a58.tar.gz
weston: plane_add_prop() calls break musl atomic modesetting
This patch ensures, weston/drm backend works which ends up with blank screen on musl based systems (From OE-Core rev: b3a5b64f717b39536c96627ce058cf9c51cf3ba6) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 95d75556dc..113f0ff599 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -38,14 +38,6 @@ do_install() {
38 sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start 38 sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start
39} 39}
40 40
41do_install_append_libc-musl_qemux86() {
42 echo "WESTON_DISABLE_ATOMIC=Y" >> ${D}${sysconfdir}/default/weston
43}
44
45do_install_append_libc-musl_qemux86-64() {
46 echo "WESTON_DISABLE_ATOMIC=Y" >> ${D}${sysconfdir}/default/weston
47}
48
49inherit update-rc.d features_check systemd 41inherit update-rc.d features_check systemd
50 42
51# rdepends on weston which depends on virtual/egl 43# rdepends on weston which depends on virtual/egl