summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-conf.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2018-10-25 05:58:26 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-28 08:31:57 +0000
commit4001e1adb21b9785a19669968f07166f5b8772cd (patch)
tree5d9183dcb1053d05f3a5bcae29d6fd92fa6e390f /meta/recipes-graphics/wayland/weston-conf.bb
parent4046716c2f315308048d568e5b606382ef7bc38b (diff)
downloadpoky-4001e1adb21b9785a19669968f07166f5b8772cd.tar.gz
weston: Split out machine specific configuration
Weston needs to be configured to load the fbdev driver when run on a QEMU system. Other MACHINEs may want to also provider their own configuration as well.. Adding a new RRECOMMEND configuration package will allow this, but avoid installing empty packages/files in the majority case where it is not needed. Add maintainer entry as well. (From OE-Core rev: 0f43ea8510ae6148a49eb25accac407b6b301b43) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-conf.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-conf.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston-conf.bb b/meta/recipes-graphics/wayland/weston-conf.bb
new file mode 100644
index 0000000000..f52200c46a
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston-conf.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Weston, a Wayland compositor, configuration files"
2HOMEPAGE = "http://wayland.freedesktop.org"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8CONFFILES_${PN} = "${sysconfdir}/xdg/weston/weston.ini"
9
10FILES_${PN} = "${sysconfdir}/xdg/weston/weston.ini"
11
12PACKAGES = "${PN}"
13
14do_configure[noexec] = '1'
15do_compile[noexec] = '1'
16
17do_install() {
18 :
19}
20
21do_install_qemux86() {
22 mkdir -p ${D}/${sysconfdir}/xdg/weston
23 cat << EOF > ${D}/${sysconfdir}/xdg/weston/weston.ini
24[core]
25backend=fbdev-backend.so
26EOF
27}
28
29do_install_qemux86-64() {
30 mkdir -p ${D}/${sysconfdir}/xdg/weston
31 cat << EOF > ${D}/${sysconfdir}/xdg/weston/weston.ini
32[core]
33backend=fbdev-backend.so
34EOF
35}