summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.9.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-01-19 21:49:05 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:22 +0000
commit1bc0c89595f1914c6f9e73a183f3115d7d793017 (patch)
tree06bcf5b46bc59f76e55add4f1c0791195b8a3301 /meta/recipes-graphics/wayland/wayland_1.9.0.bb
parent03dae8e8b3df5d1d2c98f756285ab8e7009dacf5 (diff)
downloadpoky-1bc0c89595f1914c6f9e73a183f3115d7d793017.tar.gz
wayland: upgrade 1.8.1 -> 1.9.0
* The license was updated from MIT X11 to MIT Expat. * always-build-scanner.patch was accepted upstream. * disable-macro-checks-not-used-for-scanner.patch is no longer needed with the new --disable-libraries flag. (From OE-Core rev: 696895e39715e9e9da70a85d16fec3b385eec549) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.9.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.9.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.9.0.bb b/meta/recipes-graphics/wayland/wayland_1.9.0.bb
new file mode 100644
index 0000000000..d12ac186cd
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.9.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "5e141b3f2a7005d6c89d6f233c87c317"
15SRC_URI[sha256sum] = "9c8770720aa0034479735f58a4dc4ca9b172ecfede28f5134312e135b7301efa"
16
17EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
18
19inherit autotools pkgconfig
20
21BBCLASSEXTEND = "native nativesdk"
22
23DEPENDS = "expat libffi wayland-native"
24
25EXTRA_OECONF = "--disable-documentation --with-host-scanner"
26
27# Wayland installs a M4 macro for other projects to use, which uses the target
28# pkg-config to find files. Replace pkg-config with pkg-config-native.
29do_install_append_class-native() {
30 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
31 -e 's,$PKG_CONFIG,pkg-config-native,g' \
32 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
33}
34
35sysroot_stage_all_append_class-target () {
36 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
37 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
38}
39
40FILES_${PN} = "${libdir}/*${SOLIBS}"
41FILES_${PN}-dev += "${bindir} ${datadir}/wayland"