summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.15.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-04-10 15:06:09 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:04 +0100
commit8097bf7012a0d97d3b8b48eceb5dc20cc4ae7ca9 (patch)
tree2bc83dba7ba1d3f6239302fcacc5714ef1d2f9ec /meta/recipes-graphics/wayland/wayland_1.15.0.bb
parent45247cecfb2caff1e4c80a8fa6cfaa583b778955 (diff)
downloadpoky-8097bf7012a0d97d3b8b48eceb5dc20cc4ae7ca9.tar.gz
wayland: upgrade to 1.15.0
Official announcement: https://lists.freedesktop.org/archives/wayland-devel/2018-April/037767.html | libwayland-egl is now part of libwayland, and will presumably be removed | from mesa in the not too distant future. Update mesa recipe by removing corresponding libwayland-egl entries. (From OE-Core rev: 6e5952fcfc13ff4b63c9376bd41a1dbba957f425) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.15.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.15.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.15.0.bb b/meta/recipes-graphics/wayland/wayland_1.15.0.bb
new file mode 100644
index 0000000000..788105bff8
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.15.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libxml2 libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://fixpathinpcfiles.patch \
17 "
18SRC_URI[md5sum] = "b7393c17fdce9a8d383edab656c92fd2"
19SRC_URI[sha256sum] = "eb3fbebb8559d56a80ad3753ec3db800f587329067962dbf65e14488b4b7aeb0"
20
21inherit autotools pkgconfig
22
23EXTRA_OECONF = "--disable-documentation --with-host-scanner"
24EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
25
26# Wayland installs a M4 macro for other projects to use, which uses the target
27# pkg-config to find files. Replace pkg-config with pkg-config-native.
28do_install_append_class-native() {
29 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
30 -e 's,$PKG_CONFIG,pkg-config-native,g' \
31 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
32}
33
34sysroot_stage_all_append_class-target () {
35 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
36 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
37}
38
39FILES_${PN} = "${libdir}/*${SOLIBS}"
40FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
41
42BBCLASSEXTEND = "native nativesdk"