summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/waffle/waffle_1.6.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-08-06 12:44:36 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:15 +0100
commit48a979be5415aeb7163a6854330238bd8c61cfc7 (patch)
treed1b331bd4a0bfa2129ac2bcdacaef9bb9e8db16b /meta/recipes-graphics/waffle/waffle_1.6.0.bb
parent58beb4fd3d5509a336eeebbc1354687b746589e8 (diff)
downloadpoky-48a979be5415aeb7163a6854330238bd8c61cfc7.tar.gz
waffle: upgrade 1.5.2 -> 1.6.0
Switch to Meson instead of CMake. Add PACKAGECONFIG for surfaceless-egl. Inherit bash-completion for the new wlinfo completion script. (From OE-Core rev: 96decf673992b1cd1eebac45a5cd534eef27ebd7) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/waffle/waffle_1.6.0.bb')
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.6.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.6.0.bb b/meta/recipes-graphics/waffle/waffle_1.6.0.bb
new file mode 100644
index 0000000000..8a1d5748f6
--- /dev/null
+++ b/meta/recipes-graphics/waffle/waffle_1.6.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
6SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz"
7SRC_URI[md5sum] = "61bfc1a478e840825f33ddb4057115e7"
8SRC_URI[sha256sum] = "d9c899f710c50cfdd00f5f4cdfeaef0687d8497362239bdde93bed6c909c81d7"
9
10UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
11
12inherit meson distro_features_check lib_package bash-completion
13
14# This should be overridden per-machine to reflect the capabilities of the GL
15# stack.
16PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \
17 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
18 surfaceless-egl gbm"
19
20# virtual/libgl requires opengl in DISTRO_FEATURES.
21REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}"
22
23# I say virtual/libgl, actually wants gl.pc
24PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/${MLPREFIX}libgl libx11"
25
26# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
27# DISTRO_FEATURE.
28PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,virtual/${MLPREFIX}libgl wayland"
29
30# I say virtual/libgl, actually wants gbm.pc egl.pc
31PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/${MLPREFIX}libgl udev"
32
33# I say virtual/libgl, actually wants egl.pc
34PACKAGECONFIG[x11-egl] = "-Dx11_egl=enabled,-Dx11_egl=disabled,virtual/${MLPREFIX}libgl libxcb"
35PACKAGECONFIG[surfaceless-egl] = "-Dsurfaceless_egl=enabled,-Dsurfaceless_egl=disabled,virtual/${MLPREFIX}libgl"
36
37# TODO: optionally build manpages and examples