summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-03-08 15:21:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-10 14:50:10 +0000
commit3835f04fc35228178fdac5d4f7c8a72b9568c330 (patch)
tree017146c7cfab02eaa626cafdc94a072a07871102 /meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb
parentc09a6bd8e26ed1e1bbfdf8e711cd3ed1e58ceaee (diff)
downloadpoky-3835f04fc35228178fdac5d4f7c8a72b9568c330.tar.gz
vulkan: Add recipe for Vulkan common loader
Add a recipe for vulkan loader library and the vulkaninfo binary. Vulkan can be built to support X11 or wayland or both. There is currently no support for building tests, validation layers or even the demos as that would require a bunch of otherwise unnecessary dependencies. Fix the build on musl by defaulting to getenv() if secure_getenv() is not available. (From OE-Core rev: ce0acee244cdae287fa0d3b048d371627a69a030) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb b/meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb
new file mode 100644
index 0000000000..45d1c493e2
--- /dev/null
+++ b/meta/recipes-graphics/vulkan/vulkan_1.0.39.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "3D graphics and compute API common loader"
2DESCRIPTION = "Vulkan is a new generation graphics and compute API \
3that provides efficient access to modern GPUs. These packages \
4provide only the common vendor-agnostic library loader, headers and \
5the vulkaninfo utility."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=99c647ca3d4f6a4b9d8628f757aad156 \
12 file://loader/loader.c;endline=25;md5=a87cd5442291c23d1fce4eece4cfde9d"
13SRC_URI = "git://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git;branch=sdk-1.0.39 \
14 file://demos-Don-t-build-tri-or-cube.patch \
15 file://0001-Use-getenv-if-secure_getenv-does-not-exist.patch \
16"
17SRCREV = "9c21ed0fb275589c3af6118aec9ef4f1d1544dc1"
18
19S = "${WORKDIR}/git"
20
21
22inherit cmake python3native lib_package distro_features_check
23ANY_OF_DISTRO_FEATURES = "x11 wayland"
24
25EXTRA_OECMAKE = "-DBUILD_WSI_MIR_SUPPORT=OFF \
26 -DBUILD_LAYERS=OFF \
27 -DBUILD_TESTS=OFF"
28
29# must choose x11 or wayland or both
30PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '' ,d)} \
31 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '' ,d)}"
32PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON -DDEMOS_WSI_SELECTION=XCB, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF -DDEMOS_WSI_SELECTION=WAYLAND, libxcb libx11 libxrandr"
33PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
34