summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:47:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:21:10 +0000
commita9973bb87db8968ca1cf9ed4a9484b0bfa214b2a (patch)
tree074509e8d17c3ec3e7afe39533cb10b07f588602 /meta/recipes-graphics/vulkan/vulkan-demos_git.bb
parent2a157f114c0fd956bbaf004f1c5bee8a7d42ecf0 (diff)
downloadpoky-a9973bb87db8968ca1cf9ed4a9484b0bfa214b2a.tar.gz
vulkan-samples: replace vulkan-demos
vulkan-samples is the official collection, and vulkan-demos author has stated that he will be mostly contributing there: https://github.com/SaschaWillems/Vulkan#Khronossamples (From OE-Core rev: 76a25391d09de06f832c1053d3dbc901dee3b912) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/vulkan/vulkan-demos_git.bb')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-demos_git.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-demos_git.bb b/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
deleted file mode 100644
index 4175a56157..0000000000
--- a/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1DESCRIPTION = "Collection of Vulkan examples"
2LICENSE = "MIT"
3DEPENDS = "zlib"
4
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \
6 file://examples/triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa"
7
8SRCREV_glm = "1ad55c5016339b83b7eec98c31007e0aee57d2bf"
9SRCREV_ktx = "726d14d02c95bb21ec9e43807751b491d295dd3c"
10
11SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \
12 git://github.com/g-truc/glm;destsuffix=git/external/glm;name=glm \
13 git://github.com/KhronosGroup/KTX-Software;destsuffix=git/external/ktx;name=ktx;lfs=0 \
14 file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \
15 "
16UPSTREAM_CHECK_COMMITS = "1"
17SRCREV = "4818f85916bf88c1ca8c2ed1a46e0e758651489e"
18UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
19S = "${WORKDIR}/git"
20
21REQUIRED_DISTRO_FEATURES = 'vulkan'
22
23inherit cmake features_check
24DEPENDS = "vulkan-loader assimp wayland-protocols wayland-native"
25
26do_install_append () {
27 # Remove assets that have uncertain licenses
28 rm ${D}${datadir}/vulkan-demos/models/armor/* \
29 ${D}${datadir}/vulkan-demos/models/sibenik/* \
30 ${D}${datadir}/vulkan-demos/models/vulkanscene* \
31 ${D}${datadir}/vulkan-demos/models/plants.dae \
32 ${D}${datadir}/vulkan-demos/textures/texturearray_plants*
33
34 mv ${D}${bindir}/screenshot ${D}${bindir}/vulkan-screenshot
35}
36
37EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos"
38
39ANY_OF_DISTRO_FEATURES = "x11 wayland"
40
41# Can only pick one of [wayland,xcb]
42PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb', d)}"
43PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland"
44PACKAGECONFIG[xcb] = ",,libxcb"