summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-24 12:32:58 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-24 13:25:21 -0800
commit80f592c252cdaf34057ba47d140adb8a63209cd0 (patch)
treefb4e628aec961f353a2bdb8de5f34ce49d64a7d5 /meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
parentb43d82dcae78c053d41e188ed03d9c6fcb035842 (diff)
downloadpoky-80f592c252cdaf34057ba47d140adb8a63209cd0.tar.gz
liberation-fonts: Added version 1.06, PREFERRED_VERSION is still 1.04
The new recipe requires fontforge, which is not added yet, so the preferred version remains 1.04, when we have fontforge native then we can remove this. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb')
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
new file mode 100644
index 0000000000..210372be7d
--- /dev/null
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "The Liberation(tm) Fonts is a font family originally created by Ascender(c) which aims metric compatibility as usage of Arial, Times New Roman, Courier New"
2HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
3BUGTRACKER = "https://bugzilla.redhat.com/"
4
5SECTION = "x11/fonts"
6PRIORITY = "optional"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
9PACKAGE_ARCH = "all"
10RDEPENDS = "fontconfig-utils"
11PE = "1"
12PR = "r0"
13
14FONTREV = "0.20100721"
15SRC_URI = "https://fedorahosted.org/releases/l/i/${PN}/${PN}-${PV}.${FONTREV}.tar.gz \
16 file://30-liberation-aliases.conf"
17
18S = ${WORKDIR}/${PN}-${PV}.${FONTREV}
19
20do_install () {
21 install -d ${D}${datadir}/fonts/ttf/
22 for i in *.ttf; do
23 install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
24 done
25
26 install -d ${D}${sysconfdir}/fonts/conf.d/
27 install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
28
29 install -d ${D}${prefix}/share/doc/${PN}/
30 install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
31}
32
33pkg_postinst () {
34#!/bin/sh
35fc-cache
36}
37
38PACKAGES = "${PN}"
39FILES_${PN} += "${sysconfdir} ${datadir}"