summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/tslib/tslib_1.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-16 14:33:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-20 15:31:25 +0100
commita42db118a74f7b4dc4789969f9761b3c7ee41c11 (patch)
tree79f92f66d6dcbc60104a543fbc4b809b6862bdeb /meta/recipes-graphics/tslib/tslib_1.1.bb
parenta8d686ba22264e84d4e094744e766bbfd707408d (diff)
downloadpoky-a42db118a74f7b4dc4789969f9761b3c7ee41c11.tar.gz
tslib: update to 1.1
Drop patches merged upstream. 32bitBE-support.patch wasn't merged, but no longer applies and similar changes look to have been made; tslib 1.1 works properly on qemumips without it, so this has also been dropped. (From OE-Core rev: 2e92d845b433f3a1805c310ccda54cfc7dd8b1e1) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/tslib/tslib_1.1.bb')
-rw-r--r--meta/recipes-graphics/tslib/tslib_1.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-graphics/tslib/tslib_1.1.bb b/meta/recipes-graphics/tslib/tslib_1.1.bb
new file mode 100644
index 0000000000..4dce8a79dc
--- /dev/null
+++ b/meta/recipes-graphics/tslib/tslib_1.1.bb
@@ -0,0 +1,55 @@
1SUMMARY = "An abstraction layer for touchscreen panel events."
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.berlios.de/"
7
8AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
9SECTION = "base"
10LICENSE = "LGPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
12
13SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
14 file://ts.conf \
15 file://tslib.sh \
16"
17
18SRC_URI[md5sum] = "14771f8607b341bb4b297819d37e837d"
19SRC_URI[sha256sum] = "fe35e5f710ea933b118f710e2ce4403ac076fe69926b570333867d4de082a51c"
20
21
22inherit autotools pkgconfig
23
24EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
25
26do_install_prepend() {
27 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
28}
29
30do_install_append() {
31 install -d ${D}${sysconfdir}/profile.d/
32 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
33}
34
35SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
36
37# People should consider using udev's /dev/input/touchscreen0 symlink
38# instead of detect-stylus
39#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
40RPROVIDES_tslib-conf = "libts-0.0-conf"
41
42PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
43DEBIAN_NOAUTONAME_tslib-conf = "1"
44DEBIAN_NOAUTONAME_tslib-tests = "1"
45DEBIAN_NOAUTONAME_tslib-calibrate = "1"
46
47RDEPENDS_${PN} = "tslib-conf"
48RRECOMMENDS_${PN} = "pointercal"
49
50FILES_${PN}-dbg += "${libdir}/ts/.debug*"
51FILES_${PN}-dev += "${libdir}/ts/*.la"
52FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
53FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
54FILES_tslib-calibrate += "${bindir}/ts_calibrate"
55FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"