summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-13 20:00:33 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:28:48 +0100
commitc3753a8b187c24fcac57c37c8a6d98be64af9f3b (patch)
tree89554edcd646057532928f5d238efa97f83091b6 /meta/recipes-graphics/piglit/piglit_git.bb
parentb384b724ec51da702ee42ace4c38546fc16f296f (diff)
downloadpoky-c3753a8b187c24fcac57c37c8a6d98be64af9f3b.tar.gz
piglit: Upgrade version, use python3
* Remove backported patch * Update dependencies to use python3 modules, add depencies added in the new version * Install only stripped binaries to keep size down * Fix bash-completion install location (From OE-Core rev: f7193a306cfc3ac0a3fdcf891716a59f5b8178e8) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb25
1 files changed, 15 insertions, 10 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 607f236c2a..f5ef364492 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -3,18 +3,19 @@ LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4 4
5SRC_URI = "git://anongit.freedesktop.org/piglit \ 5SRC_URI = "git://anongit.freedesktop.org/piglit \
6 file://0001-tests-Fix-missing-include-of-Xutil.h.patch" 6 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 "
7 8
8# From 2015-02-19 9# From 2016-07-07
9SRCREV = "c4585427913e4cb28994b4bfb11d49778273aa2c" 10SRCREV = "c39e41a86551eb390b8da23232dc8577639403d0"
10# (when PV goes above 1.0 remove the trailing r) 11# (when PV goes above 1.0 remove the trailing r)
11PV = "1.0+gitr${SRCPV}" 12PV = "1.0+gitr${SRCPV}"
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
14 15
15DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native" 16DEPENDS = "libpng virtual/libx11 libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native"
16 17
17inherit cmake pythonnative distro_features_check 18inherit cmake python3native distro_features_check bash-completion
18# depends on virtual/libx11 19# depends on virtual/libx11
19REQUIRED_DISTRO_FEATURES = "x11" 20REQUIRED_DISTRO_FEATURES = "x11"
20 21
@@ -34,10 +35,14 @@ do_configure_prepend() {
34 fi 35 fi
35} 36}
36 37
37RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \ 38do_install() {
38 python-argparse python-importlib python-unixadmin python-xml \ 39 oe_runmake -C ${B} 'DESTDIR=${D}' install/strip
39 python-multiprocessing python-textutils python-netserver python-shell \ 40}
40 mesa-demos bash \ 41
42RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
43 python3-subprocess python3-misc python3-importlib \
44 python3-unixadmin python3-xml python3-multiprocessing \
45 python3-six python3-shell python3-io mesa-demos bash \
41 " 46 "
42 47
43INSANE_SKIP_${PN} += "dev-so" 48INSANE_SKIP_${PN} += "dev-so already-stripped"