summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-06-18 17:18:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-27 22:42:51 +0100
commit8b4f659ec910e2fc8b8ef96484292e458b3f8bac (patch)
tree2d59f628ae11cf24dcf01aa5e9f00d129d4bc222 /meta/recipes-graphics/piglit/piglit_git.bb
parent612244675d8407dc183c20872b679800b745dc3b (diff)
downloadpoky-8b4f659ec910e2fc8b8ef96484292e458b3f8bac.tar.gz
piglit: fix floating dependence on freeglut
cmake can not handle "ifdef" and make floating dependence on freeglut_ext.h when make_depend, so remove to include freeglut_ext.h from header file if freegult is not in PACKAGECONFIG to fix this issue (From OE-Core rev: 71158fa1a623125dae82c64c27e81dcdb2369e2d) Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 9e6dc2c406..3a8b0acfa2 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -21,6 +21,12 @@ REQUIRED_DISTRO_FEATURES = "x11"
21PACKAGECONFIG ??= "" 21PACKAGECONFIG ??= ""
22PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut," 22PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
23 23
24do_configure_prepend() {
25 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
26 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
27 fi
28}
29
24FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/" 30FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
25 31
26RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \ 32RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \