summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-10 20:19:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:59:18 +0100
commit346769c12081ede03724bab389a021f8f5180db9 (patch)
tree12ac8e15f639c9fcd4a94c581ca55413f2c39e2b /meta/recipes-graphics/piglit/piglit_git.bb
parent7b08012204e0a004b3d1f332df5bc3a250d71762 (diff)
downloadpoky-346769c12081ede03724bab389a021f8f5180db9.tar.gz
piglit: upgrade to more recent srvrev
Upgrade to 126c7d from December 2014. Still not the latest but it's got no added build dependencies and importantly handles installs out of the box instead of us having to hack and kludge, and builds with cmake 3.x. The usage has changed: now there's a "piglit" binary that has run/resume/summary subcommands, for example: $ piglit run quick quick-results/ For reference the quick test suite on a IvyBridge NUC results in: [27714/27714] crash: 3, fail: 326, pass: 18275, skip: 9107, warn: 3 - (From OE-Core rev: 562c8907d6afcf50695f8964cdebd05fc1085742) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb37
1 files changed, 6 insertions, 31 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index e33e4a7237..75e41fefc2 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -4,8 +4,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4 4
5SRC_URI = "git://anongit.freedesktop.org/piglit" 5SRC_URI = "git://anongit.freedesktop.org/piglit"
6 6
7# From 2012/12/30. 7# From 2014/12/04
8SRCREV = "bbeff5d21b06d37338ad28e42d88f499bef13268" 8SRCREV = "126c7d049b8f32e541625d5a35fbc5f5e4e7fbf8"
9# (when PV goes above 1.0 remove the trailing r) 9# (when PV goes above 1.0 remove the trailing r)
10PV = "1.0+gitr${SRCPV}" 10PV = "1.0+gitr${SRCPV}"
11 11
@@ -17,40 +17,15 @@ inherit cmake pythonnative distro_features_check
17# depends on virtual/libx11 17# depends on virtual/libx11
18REQUIRED_DISTRO_FEATURES = "x11" 18REQUIRED_DISTRO_FEATURES = "x11"
19 19
20# As piglit doesn't install, enforce in-tree builds so that we can easily copy
21# contents out of $S and $B.
22B="${S}"
23
24PACKAGECONFIG ??= "" 20PACKAGECONFIG ??= ""
25PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut," 21PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
26 22
27# CMake sets the rpath at build time with the source tree, and will reset it at
28# install time. As we don't install this doesn't happen, so force the rpath to
29# what we need.
30EXTRA_OECMAKE = "-DCMAKE_BUILD_WITH_INSTALL_RPATH=1 -DCMAKE_INSTALL_RPATH=${libdir}/piglit/lib"
31
32do_install() {
33 install -d ${D}${bindir}
34 install -m 0755 piglit-*.py ${D}${bindir}
35
36 install -d ${D}${libdir}/piglit/
37
38 install -d ${D}${libdir}/piglit/bin
39 install -m 755 ${S}/bin/* ${D}${libdir}/piglit/bin
40
41 cp -Pr lib/ ${D}${libdir}/piglit/
42 cp -Pr framework/ ${D}${libdir}/piglit/
43 cp -Pr generated_tests/ ${D}${libdir}/piglit/
44 cp -Pr tests/ ${D}${libdir}/piglit/
45 cp -Pr templates/ ${D}${libdir}/piglit/
46
47 sed -i -e 's|sys.path.append(.*)|sys.path.append("${libdir}/piglit")|' ${D}${bindir}/piglit-*.py
48 sed -i -e 's|^templatedir = .*$|templatedir = "${libdir}/piglit/templates"|' ${D}${bindir}/piglit-summary-html.py
49}
50
51FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/" 23FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
52 24
53RDEPENDS_${PN} = "python waffle python-json python-subprocess \ 25RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \
26 python-argparse python-importlib python-unixadmin \
54 python-multiprocessing python-textutils python-netserver python-shell \ 27 python-multiprocessing python-textutils python-netserver python-shell \
55 mesa-demos bash \ 28 mesa-demos bash \
56 " 29 "
30
31INSANE_SKIP_${PN} += "dev-so" \ No newline at end of file