summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_17.1.7.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-08-24 15:06:51 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-27 22:30:06 +0100
commit3e9b5f9e2d0b6de2d9286be3fc2b56d4f731a687 (patch)
tree9c9794d521a16f189a0643a2299e8416ef9fdd1e /meta/recipes-graphics/mesa/mesa_17.1.7.bb
parent8a93eaad27ec781cd74bb6bb8f78b33fe68101e2 (diff)
downloadpoky-3e9b5f9e2d0b6de2d9286be3fc2b56d4f731a687.tar.gz
mesa: Upgrade to 17.1.7 release
This is a bugfix release and has following upstream bugs as noteworth: Bug 101334 - AMD SI cards: Some vulkan apps freeze the system Bug 101766 - Assertion `!"invalid type"' failed when constant expression involves literal of different type Bug 102024 - FORMAT_FEATURE_SAMPLED_IMAGE_BIT not supported for D16_UNORM and D32_SFLOAT Bug 102148 - Crash when running qopenglwidget example on mesa llvmpipe win32 Bug 102241 - gallium/wgl: SwapBuffers freezing regularly with swap interval enabled (From OE-Core rev: 4d6b5b85508f1b55c9ae38a9a9bb82e060e3c793) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_17.1.7.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.7.bb b/meta/recipes-graphics/mesa/mesa_17.1.7.bb
new file mode 100644
index 0000000000..494cdc6d83
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_17.1.7.bb
@@ -0,0 +1,23 @@
1require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://replace_glibc_check_with_linux.patch \
5 file://disable-asm-on-non-gcc.patch \
6 file://0001-Use-wayland-scanner-in-the-path.patch \
7 file://0002-hardware-gloat.patch \
8 file://vulkan-mkdir.patch \
9 file://llvm-config-version.patch \
10 file://0001-ac-fix-build-after-LLVM-5.0-SVN-r300718.patch \
11 file://0002-gallivm-Fix-build-against-LLVM-SVN-r302589.patch \
12 file://0001-winsys-svga-drm-Include-sys-types.h.patch \
13 "
14SRC_URI[md5sum] = "e40bb428a263bd28cbf6478dae45b207"
15SRC_URI[sha256sum] = "69f472a874b1122404fa0bd13e2d6bf87eb3b9ad9c21d2f39872a96d83d9e5f5"
16
17#because we cannot rely on the fact that all apps will use pkgconfig,
18#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
19do_install_append() {
20 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
21 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
22 fi
23}