summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 22:51:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 23:05:04 +0100
commit7a97bf7976666bbcfd81052ff8c90d1f52901910 (patch)
treea54c06ed2d614150135fc361e1d5ecec928ff8d4 /meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
parent2cf9fb4df498fe0e4fa8356dc663fdfdec9a98cc (diff)
downloadpoky-7a97bf7976666bbcfd81052ff8c90d1f52901910.tar.gz
mesa: Update 7.8.2 -> 7.11
Pieces of this taken from patches from Martin Jansa <martin.jansa@gmail.com> and likely from meta-oe. It includes just enough changes to get the newer version to build. (From OE-Core rev: b2252d16b46bc18ff0aa06efaf58dd337682f587) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-xlib_7.11.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-xlib_7.11.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb b/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
new file mode 100644
index 0000000000..ea4acc6295
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-xlib_7.11.bb
@@ -0,0 +1,30 @@
1include mesa-common.inc
2
3FILESPATH =. "${FILE_DIRNAME}/mesa-dri:"
4
5SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
6 file://uclibc.patch \
7 "
8
9SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
10SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
11
12LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
13
14PROTO_DEPS = "xf86driproto glproto"
15LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
16
17DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} makedepend-native"
18
19PE = "1"
20PR = "r1"
21
22EXTRA_OECONF += "--with-driver=xlib --without-gallium-drivers"
23
24do_configure_prepend() {
25 #check for python not python2, because python-native does not stage python2 binary/link
26 sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
27 # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
28 sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
29}
30