summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-graphics/mesa/mesa-dri_git.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_git.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_git.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_git.bb b/meta/recipes-graphics/mesa/mesa-dri_git.bb
new file mode 100644
index 0000000000..fa0a7c8dc2
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri_git.bb
@@ -0,0 +1,59 @@
1include mesa-common.inc
2
3SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
4 file://cross2.patch;patch=1 \
5 file://matypes.h"
6# file://mesa-DRI2Swapbuffer.patch;patch=1 "
7S = "${WORKDIR}/git"
8
9PROTO_DEPS = "xf86driproto glproto dri2proto"
10LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
11
12DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
13
14PV = "7.7+git${SRCPV}"
15PR = "r0"
16
17# most of our targets do not have DRI so will use mesa-xlib
18DEFAULT_PREFERENCE = "-1"
19
20# Netbooks have DRI support so use mesa-dri by default
21DEFAULT_PREFERENCE_netbook = "1"
22
23PACKAGES =+ "${PN}-xprogs"
24PACKAGES_DYNAMIC = "mesa-dri-driver-*"
25
26FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
27FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
28
29LEAD_SONAME = "libGL.so.1"
30
31EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
32
33do_configure_prepend () {
34 cp ${WORKDIR}/matypes.h ${S}/src/mesa/x86
35 touch ${S}/src/mesa/x86/matypes.h
36}
37
38do_compile () {
39 oe_runmake clean
40 oe_runmake -C src/glsl CC='${BUILD_CC}' CFLAGS=""
41 mv ${S}/src/glsl/apps/compile ${S}/host_compile
42 oe_runmake clean
43 oe_runmake GLSL_CL="${S}/host_compile"
44}
45
46do_install_append () {
47 install -d ${D}/usr/bin
48 install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
49}
50
51python populate_packages_prepend() {
52 import os.path
53
54 dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri")
55
56 do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='')
57}
58
59COMPATIBLE_HOST = '(i.86|x86_64).*-linux'