diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb')
-rw-r--r-- | meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb new file mode 100644 index 0000000000..ffd885f293 --- /dev/null +++ b/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | include mesa-common.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d" | ||
4 | |||
5 | PROTO_DEPS = "xf86driproto glproto dri2proto" | ||
6 | LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat" | ||
7 | |||
8 | DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} mesa-dri-glsl-native" | ||
9 | |||
10 | PR = "r1" | ||
11 | |||
12 | SRC_URI += "file://crossfix.patch" | ||
13 | |||
14 | # most of our targets do not have DRI so will use mesa-xlib | ||
15 | DEFAULT_PREFERENCE = "-1" | ||
16 | |||
17 | # Netbooks have DRI support so use mesa-dri by default | ||
18 | DEFAULT_PREFERENCE_netbook = "1" | ||
19 | |||
20 | LEAD_SONAME = "libGL.so.1" | ||
21 | |||
22 | EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium" | ||
23 | |||
24 | # We need glsl-compile built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)" | ||
25 | do_configure_prepend() { | ||
26 | sed -i "s#^GLSL_CL = .*\$#GLSL_CL = ${STAGING_BINDIR_NATIVE}/glsl-compile#g" ${S}/src/mesa/shader/slang/library/Makefile | ||
27 | } | ||
28 | |||
29 | do_install_append () { | ||
30 | install -d ${D}/usr/bin | ||
31 | install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/ | ||
32 | } | ||
33 | |||
34 | python populate_packages_prepend() { | ||
35 | import os.path | ||
36 | |||
37 | dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri") | ||
38 | |||
39 | do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='') | ||
40 | } | ||
41 | |||
42 | COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)' | ||
43 | |||
44 | PACKAGES =+ "${PN}-xprogs" | ||
45 | PACKAGES_DYNAMIC = "mesa-dri-driver-*" | ||
46 | |||
47 | FILES_${PN}-dbg += "${libdir}/dri/.debug/*" | ||
48 | FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo" | ||
49 | |||
50 | # | ||
51 | # Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl | ||
52 | # then run gen_matypes > matypes.h on device | ||
53 | # | ||