summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 22:51:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 23:05:04 +0100
commit7a97bf7976666bbcfd81052ff8c90d1f52901910 (patch)
treea54c06ed2d614150135fc361e1d5ecec928ff8d4 /meta/recipes-graphics/mesa/mesa-dri_7.11.bb
parent2cf9fb4df498fe0e4fa8356dc663fdfdec9a98cc (diff)
downloadpoky-7a97bf7976666bbcfd81052ff8c90d1f52901910.tar.gz
mesa: Update 7.8.2 -> 7.11
Pieces of this taken from patches from Martin Jansa <martin.jansa@gmail.com> and likely from meta-oe. It includes just enough changes to get the newer version to build. (From OE-Core rev: b2252d16b46bc18ff0aa06efaf58dd337682f587) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.11.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.11.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.11.bb b/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
new file mode 100644
index 0000000000..6fc8d95e73
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.11.bb
@@ -0,0 +1,48 @@
1include mesa-common.inc
2
3LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
4
5PROTO_DEPS = "xf86driproto glproto dri2proto"
6LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
7 libxml2-native"
8
9DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} makedepend-native python-native"
10DEPENDS += "mesa-dri-glsl-native"
11
12PR = "r5"
13
14SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
15 file://crossfix.patch \
16 file://uclibc.patch \
17 "
18
19SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
20SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
21
22# most of our targets do not have DRI so will use mesa-xlib
23DEFAULT_PREFERENCE = "-1"
24
25LEAD_SONAME = "libGL.so.1"
26
27EXTRA_OECONF += "--with-driver=dri --disable-egl -with-dri-drivers=swrast,i915,i965 --without-gallium-drivers"
28
29python populate_packages_prepend() {
30 import os.path
31
32 dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri")
33
34 do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='')
35}
36
37COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
38
39PACKAGES_DYNAMIC = "mesa-dri-driver-*"
40
41FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
42
43do_configure_prepend() {
44 #check for python not python2, because python-native does not stage python2 binary/link
45 sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
46 # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
47 sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
48}