summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 22:51:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 23:05:04 +0100
commit7a97bf7976666bbcfd81052ff8c90d1f52901910 (patch)
treea54c06ed2d614150135fc361e1d5ecec928ff8d4 /meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb
parent2cf9fb4df498fe0e4fa8356dc663fdfdec9a98cc (diff)
downloadpoky-7a97bf7976666bbcfd81052ff8c90d1f52901910.tar.gz
mesa: Update 7.8.2 -> 7.11
Pieces of this taken from patches from Martin Jansa <martin.jansa@gmail.com> and likely from meta-oe. It includes just enough changes to get the newer version to build. (From OE-Core rev: b2252d16b46bc18ff0aa06efaf58dd337682f587) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb
new file mode 100644
index 0000000000..07247d5edb
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.11.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "gl shader language specific build from mesa-dri"
2HOMEPAGE = "http://mesa3d.org"
3BUGTRACKER = "https://bugs.freedesktop.org"
4SECTION = "x11"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://glsl_parser.cpp;beginline=3;endline=33;md5=d078f1cddc2fc355719c090482254bd9"
7
8DEPENDS = "makedepend-native"
9
10SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
11SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
12SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
13
14S = "${WORKDIR}/Mesa-${PV}/src/glsl/"
15
16inherit native
17
18# use default config for native build
19do_configure_prepend() {
20 ln -s ${S}/../../configs/default ${S}/../../configs/current
21}
22
23do_install() {
24 install -d ${D}/${bindir}/glsl
25 install -m 755 ${S}/builtin_compiler ${D}/${bindir}/glsl/builtin_compiler
26 install -m 755 ${S}/glsl_compiler ${D}/${bindir}/glsl/glsl_compiler
27}