summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-01-26 19:14:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 16:49:12 +0000
commit1b26bce9675f1beb3d0370f49fc5ed9709c979f6 (patch)
tree7a24e783ae68cc1c26c0c8ba16c4e1e53af97ac7 /meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
parent5612838d7e7f958633d211a186ab1cbab2803805 (diff)
downloadpoky-1b26bce9675f1beb3d0370f49fc5ed9709c979f6.tar.gz
matchbox: Convert all the matchbox components' repo from svn to git including:
matchbox-wm matchbox-panel-2 matchbox-terminal matchbox-config-gtk matchbox-stroke matchbox-desktop matchbox-keyboard matchbox-themes-extra libfakekey settings-daemon Also remove some old recipes. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
new file mode 100644
index 0000000000..086d4853e4
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Matchbox window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
7 file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
8 file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf"
12
13PV = "1.2+git${SRCPV}"
14PR = "r0"
15
16SRC_URI = "git://git.pokylinux.org/matchbox-window-manager;protocol=git \
17 file://configure_fix.patch;patch=1;maxrev=1818 \
18 file://kbdconfig"
19
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig update-alternatives
23
24ALTERNATIVE_NAME = "x-session-manager"
25ALTERNATIVE_LINK = "${bindir}/x-session-manager"
26ALTERNATIVE_PATH = "${bindir}/matchbox-session"
27ALTERNATIVE_PRIORITY = "10"
28
29FILES_${PN} = "${bindir}/* \
30 ${datadir}/matchbox \
31 ${sysconfdir}/matchbox \
32 ${datadir}/themes/blondie/matchbox \
33 ${datadir}/themes/Default/matchbox \
34 ${datadir}/themes/MBOpus/matchbox"
35
36EXTRA_OECONF = " --enable-startup-notification \
37 --disable-xrm \
38 --enable-expat \
39 --with-expat-lib=${STAGING_LIBDIR} \
40 --with-expat-includes=${STAGING_INCDIR}"
41
42do_install_prepend() {
43 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
44}