summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.2.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-07-13 10:39:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-18 10:18:42 +0100
commitad76eb195b3a074401808081451ee1a891083464 (patch)
treed60400b2806a341a712200883ce805b3708f48ba /meta/recipes-graphics/libva/libva_2.2.0.bb
parent90a06269df747aa9e08a9b904cf6529cc2ee0027 (diff)
downloadpoky-ad76eb195b3a074401808081451ee1a891083464.tar.gz
libva: upgrade 2.1.0 -> 2.2.0
* Bump VA-API version to 1.2.0 * Add support for hevc range extension decoding * Add support for fast intra prediction in HEVC FEI * Add 10/12-bit YUV render target formats * Add fourcc code for Y210/Y216/Y410/Y416/RGB565/BGR565 * Add VA_STATUS_ERROR_NOT_ENOUGH_BUFFER * Add VA_SURFACE_ATTRIB_USAGE_HINT_EXPORT * Improve documentation Tested with Intel vaapi driver. There is support for meson available but its not being packaged as part of release tarball yet. (From OE-Core rev: d61d417750d4eadf5a00760e9859cb4c3b233cdc) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.2.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.2.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.2.0.bb b/meta/recipes-graphics/libva/libva_2.2.0.bb
new file mode 100644
index 0000000000..11e57e0eb8
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.2.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
21
22SRC_URI[md5sum] = "92d04ad1700136dc75b1e5f47516e704"
23SRC_URI[sha256sum] = "6f6ca04c785544d30d315ef130a6aeb9435b75f934d7fbe0e4e9ba6084ce4ef2"
24
25UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
26
27DEPENDS = "libdrm virtual/mesa"
28
29inherit autotools pkgconfig distro_features_check
30
31REQUIRED_DISTRO_FEATURES = "opengl"
32
33EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
34
35PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
36PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
37PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
38
39PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
40
41RDEPENDS_${PN}-x11 =+ "${PN}"
42RDEPENDS_${PN}-glx =+ "${PN}-x11"
43
44FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
45FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
46FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"