summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva-utils_2.0.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-06 10:04:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-16 18:05:39 +0000
commitbf87d60cb5f816e364f25b6208a9d98300b1ff0e (patch)
tree85bf8b0313d3e3bd403cfeba07e5f62e53e16dd2 /meta/recipes-graphics/libva/libva-utils_2.0.0.bb
parent618fa564d1ec44160bb997a617cdc36e029387e8 (diff)
downloadpoky-bf87d60cb5f816e364f25b6208a9d98300b1ff0e.tar.gz
libva-utils: upgrade to 2.0.0
Major changes: * Add option '--device <device>' to vainfo * Add vp9enc for VP9 encoding * Add vavpp for video processing * Add FEI gtest cases * Fix segmentation fault in putsurface_wayland * Fix GCC 7.1.1 warnings/errors * Fix libva version printed out by vainfo Updated recipe to point to release tarball instead of git. Also, updated github URLs to point to renamed Intel repository. (From OE-Core rev: f355e40c84de55a7f71165873dbe7ef1ea870b83) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libva/libva-utils_2.0.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva-utils_2.0.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva-utils_2.0.0.bb b/meta/recipes-graphics/libva/libva-utils_2.0.0.bb
new file mode 100644
index 0000000000..f69fab9354
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva-utils_2.0.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "libva-utils is a collection of utilities from libva project"
2
3DESCRIPTION = "libva-utils is a collection of utilities \
4and examples to exercise VA-API in accordance with the libva \
5project.VA-API is an open-source library and API specification, \
6which provides access to graphics hardware acceleration capabilities \
7for video processing. It consists of a main library and driver-specific \
8acceleration backends for each supported hardware vendor"
9
10HOMEPAGE = "https://01.org/linuxmedia/vaapi"
11BUGTRACKER = "https://github.com/intel/libva-utils/issues"
12
13SECTION = "x11"
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16
17SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
18SRC_URI[md5sum] = "60fd49a60ef96ebfb559374d412e1fc4"
19SRC_URI[sha256sum] = "a921df31311d8f49d2e392a5fc2a068d79f89aeb588309fbff24365310dbc5f6"
20
21UPSTREAM_CHECK_URI = "https://github.com/intel/libva-utils/releases"
22
23DEPENDS = "libva"
24
25inherit autotools pkgconfig distro_features_check
26
27# depends on libva which requires opengl
28REQUIRED_DISTRO_FEATURES = "opengl"
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
31PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"