diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2019-07-29 11:20:25 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-07-31 13:50:46 +0100 |
commit | 07ba3a1d7320946c22a3dafefcb2aab6b1906b90 (patch) | |
tree | afbc461770f0b81cc9207de97c1a531fc687e852 /meta/recipes-graphics/libsdl2/libsdl2_2.0.10.bb | |
parent | 01f3a0cd730519a3a3402082a53ed7814d58a427 (diff) | |
download | poky-07ba3a1d7320946c22a3dafefcb2aab6b1906b90.tar.gz |
libsdl2: upgrade 2.0.9 -> 2.0.10
License-Update: Change in Copyright Year.
Refresh the patch to apply on configure.ac instead of .in.
(From OE-Core rev: f00b9aad7c3e2e1ec41597539c4fe2307043b6cf)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.10.bb')
-rw-r--r-- | meta/recipes-graphics/libsdl2/libsdl2_2.0.10.bb | 74 |
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.10.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.10.bb new file mode 100644 index 0000000000..3a0654b866 --- /dev/null +++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.10.bb | |||
@@ -0,0 +1,74 @@ | |||
1 | SUMMARY = "Simple DirectMedia Layer" | ||
2 | DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \ | ||
3 | library designed to provide low level access to audio, keyboard, mouse, \ | ||
4 | joystick, 3D hardware via OpenGL, and 2D video framebuffer." | ||
5 | HOMEPAGE = "http://www.libsdl.org" | ||
6 | BUGTRACKER = "http://bugzilla.libsdl.org/" | ||
7 | |||
8 | SECTION = "libs" | ||
9 | |||
10 | LICENSE = "Zlib" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=504a9454ceb89fd75a2583473b11409e" | ||
12 | |||
13 | PROVIDES = "virtual/libsdl2" | ||
14 | |||
15 | SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \ | ||
16 | file://more-gen-depends.patch \ | ||
17 | " | ||
18 | |||
19 | S = "${WORKDIR}/SDL2-${PV}" | ||
20 | |||
21 | SRC_URI[md5sum] = "5a2114f2a6f348bdab5bf52b994811db" | ||
22 | SRC_URI[sha256sum] = "b4656c13a1f0d0023ae2f4a9cf08ec92fffb464e0f24238337784159b8b91d57" | ||
23 | |||
24 | inherit autotools lib_package binconfig-disabled pkgconfig | ||
25 | |||
26 | BINCONFIG = "${bindir}/sdl2-config" | ||
27 | |||
28 | CVE_PRODUCT = "simple_directmedia_layer sdl" | ||
29 | |||
30 | EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \ | ||
31 | --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ | ||
32 | --disable-video-dummy \ | ||
33 | --enable-pthreads \ | ||
34 | --enable-sdl-dlopen \ | ||
35 | --disable-rpath \ | ||
36 | --disable-sndio \ | ||
37 | " | ||
38 | |||
39 | # opengl packageconfig factored out to make it easy for distros | ||
40 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL | ||
41 | PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" | ||
42 | |||
43 | PACKAGECONFIG_class-native = "x11" | ||
44 | PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | ||
45 | PACKAGECONFIG ??= " \ | ||
46 | ${PACKAGECONFIG_GL} \ | ||
47 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \ | ||
48 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \ | ||
49 | " | ||
50 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," | ||
51 | PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb" | ||
52 | PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2" | ||
53 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" | ||
54 | PACKAGECONFIG[kmsdrm] = "--enable-video-kmsdrm,--disable-video-kmsdrm,libdrm virtual/libgbm" | ||
55 | PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl" | ||
56 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" | ||
57 | PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib" | ||
58 | PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon" | ||
59 | PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender" | ||
60 | |||
61 | EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader" | ||
62 | |||
63 | do_configure_prepend() { | ||
64 | # Remove old libtool macros. | ||
65 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" | ||
66 | for i in ${MACROS}; do | ||
67 | rm -f ${S}/acinclude/$i | ||
68 | done | ||
69 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR | ||
70 | } | ||
71 | |||
72 | FILES_${PN}-dev += "${libdir}/cmake" | ||
73 | |||
74 | BBCLASSEXTEND = "native nativesdk" | ||