summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-graphics/libsdl/libsdl_1.2.15.bb')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
new file mode 100644
index 0000000000..e19c3882ad
--- /dev/null
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "LGPLv2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
12
13PROVIDES = "virtual/libsdl"
14
15DEPENDS = "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
16 ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl libglu', '', d)} \
17 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxext libxrandr libxrender', '', d)} \
18 tslib"
19DEPENDS_class-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}"
20
21PR = "r3"
22
23SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
24 file://configure_tweak.patch \
25 file://libsdl-1.2.15-xdata32.patch \
26 "
27
28S = "${WORKDIR}/SDL-${PV}"
29
30SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85"
31SRC_URI[sha256sum] = "d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00"
32
33inherit autotools lib_package binconfig pkgconfig
34
35EXTRA_OECONF = "--disable-static --enable-cdrom --enable-threads --enable-timers \
36 --enable-file --disable-oss --disable-esd --disable-arts \
37 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
38 --disable-mintaudio --disable-nasm --disable-video-dga \
39 --disable-video-fbcon --disable-video-ps2gs --disable-video-ps3 \
40 --disable-xbios --disable-gem --disable-video-dummy \
41 --enable-input-events --enable-input-tslib --enable-pthreads \
42 ${@base_contains('DISTRO_FEATURES', 'directfb', '--enable-video-directfb', '--disable-video-directfb', d)} \
43 ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-video-opengl', '--disable-video-opengl', d)} \
44 ${@base_contains('DISTRO_FEATURES', 'x11', '--enable-video-x11', '--disable-video-x11', d)} \
45 --disable-video-svga \
46 --disable-video-picogui --disable-video-qtopia --enable-sdl-dlopen \
47 --disable-rpath \
48 --disable-pulseaudio"
49
50PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
51PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
52
53PARALLEL_MAKE = ""
54
55EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
56
57do_configure_prepend() {
58 # Remove old libtool macros.
59 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
60 for i in ${MACROS}; do
61 rm -f ${S}/acinclude/$i
62 done
63 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
64}
65
66BBCLASSEXTEND = "nativesdk"