diff options
author | Changqing Li <changqing.li@windriver.com> | 2018-08-28 13:27:25 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-29 10:42:48 +0100 |
commit | c274e1c8d830f6a0cf6c78264b6527b65ef691ee (patch) | |
tree | d5787c5e3d97af6425f193a54e2fad9a308bb1ad /meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb | |
parent | 0dc9785c08939f3daa9d66741a4bb39f9fcc5fc8 (diff) | |
download | poky-c274e1c8d830f6a0cf6c78264b6527b65ef691ee.tar.gz |
libjpeg-turbo: Upgrade 1.5.3 -> 2.0.0
License-Update: Copyright Year Update
1. Upgrade from 1.5.3 -> 2.0.0, change from autools to cmake
2. Add a patch for fix package qa error
3. remove --with-build-date since 2.0.0 not support config build date
(From OE-Core rev: 83f206d68e9ae9ed21398f5cfde6f911065fbce6)
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb')
-rw-r--r-- | meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb | 62 |
1 files changed, 0 insertions, 62 deletions
diff --git a/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb b/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb deleted file mode 100644 index 6be6aa572c..0000000000 --- a/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.3.bb +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | SUMMARY = "Hardware accelerated JPEG compression/decompression library" | ||
2 | DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression" | ||
3 | HOMEPAGE = "http://libjpeg-turbo.org/" | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=8184bcc7c4ac7b9edc6a7bc00f231d0b \ | ||
7 | file://jpeglib.h;endline=16;md5=f67d70e547a2662c079781c72f877f72 \ | ||
8 | file://djpeg.c;endline=11;md5=c59e19811c006cb38f82d6477134d314 \ | ||
9 | " | ||
10 | DEPENDS_append_x86-64_class-target = " nasm-native" | ||
11 | DEPENDS_append_x86_class-target = " nasm-native" | ||
12 | |||
13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "7c82f0f6a3130ec06b8a4d0b321cbca3" | ||
16 | SRC_URI[sha256sum] = "b24890e2bb46e12e72a79f7e965f409f4e16466d00e1dd15d93d73ee6b592523" | ||
17 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libjpeg-turbo/files/" | ||
18 | UPSTREAM_CHECK_REGEX = "/libjpeg-turbo/files/(?P<pver>(\d+[\.\-_]*)+)/" | ||
19 | |||
20 | PE= "1" | ||
21 | |||
22 | # Drop-in replacement for jpeg | ||
23 | PROVIDES = "jpeg" | ||
24 | RPROVIDES_${PN} += "jpeg" | ||
25 | RREPLACES_${PN} += "jpeg" | ||
26 | RCONFLICTS_${PN} += "jpeg" | ||
27 | |||
28 | inherit autotools pkgconfig | ||
29 | |||
30 | # Add nasm-native dependency consistently for all build arches is hard | ||
31 | EXTRA_OECONF_append_class-native = " --without-simd" | ||
32 | |||
33 | # Work around missing x32 ABI support | ||
34 | EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--without-simd", "", d)}" | ||
35 | |||
36 | # Work around missing non-floating point ABI support in MIPS | ||
37 | EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "--without-simd", "", d)}" | ||
38 | |||
39 | # Provide a workaround if Altivec unit is not present in PPC | ||
40 | EXTRA_OECONF_append_class-target_powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}" | ||
41 | EXTRA_OECONF_append_class-target_powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}" | ||
42 | |||
43 | DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | ||
44 | DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | ||
45 | |||
46 | def get_build_time(d): | ||
47 | if d.getVar('SOURCE_DATE_EPOCH') != None: | ||
48 | import datetime | ||
49 | return " --with-build-date="+ datetime.datetime.utcfromtimestamp(float(d.getVar('SOURCE_DATE_EPOCH'))).strftime("%Y%m%d") | ||
50 | return "" | ||
51 | |||
52 | EXTRA_OECONF_append_class-target = "${@get_build_time(d)}" | ||
53 | |||
54 | PACKAGES =+ "jpeg-tools libturbojpeg" | ||
55 | |||
56 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library." | ||
57 | FILES_jpeg-tools = "${bindir}/*" | ||
58 | |||
59 | DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs" | ||
60 | FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*" | ||
61 | |||
62 | BBCLASSEXTEND = "native" | ||