summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-11 23:47:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-15 11:54:48 +0000
commit7c7c24960f786d830989fa0e90fa4cfb182a252b (patch)
tree50925adb09f334d0562915e68ecc5fb73bc55b5d /meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb
parent84623dc5785ef6a94507df4e3bf92370d53d4e4f (diff)
downloadpoky-7c7c24960f786d830989fa0e90fa4cfb182a252b.tar.gz
harfbuzz: update 1.1.2 -> 1.1.3
Misc recipe formatting cleanup, plus version update as described below. http://cgit.freedesktop.org/harfbuzz/tree/NEWS Overview of changes leading to 1.1.3 Monday, January 11, 2016 ==================================== - Ported Indic shaper to Unicode 8.0 data. - Universal Shaping Engine fixes. - Speed up CoreText shaper when font fallback happens in CoreText. - Documentation improvements, thanks to Khaled Hosny. - Very rough directwrite shaper for testing, thanks to Ebrahim Byagowi. - Misc bug fixes. - New API: * Font extents: hb_font_extents_t hb_font_get_font_extents_func_t hb_font_get_font_h_extents_func_t hb_font_get_font_v_extents_func_t hb_font_funcs_set_font_h_extents_func hb_font_funcs_set_font_v_extents_func hb_font_get_h_extents hb_font_get_v_extents hb_font_get_extents_for_direction * Buffer message (aka debug): hb_buffer_message_func_t hb_buffer_set_message_func() Actual message protocol to be fleshed out later. (From OE-Core rev: df2c1ea68eb21416ba058af4e33111daa1b604bd) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb
new file mode 100644
index 0000000000..ead355f226
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_1.1.3.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e021dd6dda6ff1e6b1044002fc662b9b \
8 file://src/hb-ucdn/COPYING;md5=994ba0f1295f15b4bda4999a5bbeddef \
9"
10
11DEPENDS = "glib-2.0 cairo freetype"
12
13SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.bz2"
14
15SRC_URI[md5sum] = "671daf05153d57258e5cb992aa28c64a"
16SRC_URI[sha256sum] = "d93d7cb7979c32672e902fdfa884599e63f07f2fa5b06c66147d20c516d4b8f7"
17
18inherit autotools pkgconfig lib_package
19
20PACKAGECONFIG ??= "icu"
21PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
22
23EXTRA_OECONF = "--with-glib --with-freetype --with-cairo --without-graphite2"
24
25PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
26
27FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
28FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
29 ${libdir}/libharfbuzz-icu.so \
30 ${libdir}/pkgconfig/harfbuzz-icu.pc \
31"
32
33BBCLASSEXTEND = "native"