diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2017-10-10 15:22:47 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-11-09 12:33:17 +0000 |
commit | 5f231b3d6b9a4c2b1dfbc0a345fda26000f92f69 (patch) | |
tree | 0e12ac329135fc08face4f5b048b664e6a7ef177 /meta/recipes-graphics/glew/glew_2.1.0.bb | |
parent | 30588cbbaf27c9d37e5f6d09d649fa37a8e824e8 (diff) | |
download | poky-5f231b3d6b9a4c2b1dfbc0a345fda26000f92f69.tar.gz |
glew: update to 2.1.0
(From OE-Core rev: 2c45465c4f6ebfe67bd45071abcefac7265a1caf)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/glew/glew_2.1.0.bb')
-rw-r--r-- | meta/recipes-graphics/glew/glew_2.1.0.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/glew/glew_2.1.0.bb b/meta/recipes-graphics/glew/glew_2.1.0.bb new file mode 100644 index 0000000000..be725e0530 --- /dev/null +++ b/meta/recipes-graphics/glew/glew_2.1.0.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "OpenGL extension loading library" | ||
2 | DESCRIPTION = "The OpenGL Extension Wrangler Library (GLEW) is a cross-platform open-source C/C++ extension loading library." | ||
3 | HOMEPAGE = "http://glew.sourceforge.net/" | ||
4 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=67586" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ac251558de685c6b9478d89be3149c2" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \ | ||
9 | file://no-strip.patch" | ||
10 | |||
11 | SRC_URI[md5sum] = "b2ab12331033ddfaa50dc39345343980" | ||
12 | SRC_URI[sha256sum] = "04de91e7e6763039bc11940095cd9c7f880baba82196a7765f727ac05a993c95" | ||
13 | |||
14 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/glew/files/glew" | ||
15 | UPSTREAM_CHECK_REGEX = "/glew/(?P<pver>(\d+[\.\-_]*)+)/" | ||
16 | |||
17 | inherit lib_package pkgconfig distro_features_check | ||
18 | |||
19 | REQUIRED_DISTRO_FEATURES = "opengl" | ||
20 | |||
21 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'opengl', 'egl-gles2', d)}" | ||
22 | |||
23 | # The opengl and egl-XXX options are exclusive, enable only one. | ||
24 | PACKAGECONFIG[opengl] = "SYSTEM='linux',,virtual/libx11 virtual/libgl libglu libxext libxi libxmu" | ||
25 | PACKAGECONFIG[egl-gles2] = "SYSTEM='linux-egl' GLEW_NO_GLU='-DGLEW_NO_GLU' LDFLAGS.GL='-lEGL -lGLESv2',,virtual/egl virtual/libgles2" | ||
26 | |||
27 | CFLAGS += "-D_GNU_SOURCE" | ||
28 | # Override SYSTEM (via PACKAGECONFIG_CONFARGS) to avoid calling config.guess, | ||
29 | # we're cross-compiling. Pass our CFLAGS via POPT as that's the optimisation | ||
30 | # variable and safely overwritten. | ||
31 | EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} \ | ||
32 | CC='${CC}' LD='${CC}' STRIP='' \ | ||
33 | LDFLAGS.EXTRA='${LDFLAGS}' \ | ||
34 | POPT='${CFLAGS}' \ | ||
35 | GLEW_PREFIX='${prefix}' BINDIR='${bindir}' \ | ||
36 | LIBDIR='${libdir}' INCDIR='${includedir}/GL' PKGDIR='${libdir}/pkgconfig'" | ||
37 | |||
38 | do_compile() { | ||
39 | oe_runmake | ||
40 | } | ||
41 | |||
42 | do_install() { | ||
43 | oe_runmake 'DESTDIR=${D}' install.all | ||
44 | } | ||