summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.4.9.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-06-08 17:48:15 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-11 13:55:00 +0100
commit287fabd66fc21149cccac6e5a10c2b927c1ba557 (patch)
tree584e1b5d7b2ce3b128838e124739462db8e7fa2b /meta/recipes-graphics/freetype/freetype_2.4.9.bb
parent35c5a8ce734f6b5b9483b5e546c0f3590114ea4b (diff)
downloadpoky-287fabd66fc21149cccac6e5a10c2b927c1ba557.tar.gz
freetype: upgrade to 2.4.9
(From OE-Core rev: 6dc49f00248ffb937de45c4d075907774b4cd8fc) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.4.9.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.4.9.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.4.9.bb b/meta/recipes-graphics/freetype/freetype_2.4.9.bb
new file mode 100644
index 0000000000..31bee80d68
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.4.9.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9LICENSE = "FreeType | GPLv2+"
10LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=28d5381b1bef2649c59f20c20bae4f39 \
11 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14SECTION = "libs"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
19 file://no-hardcode.patch"
20
21SRC_URI[md5sum] = "77a893dae81fd5b896632715ca041179"
22SRC_URI[sha256sum] = "c4204ac1d48e99d4375a2f32bf4f3f92780a9d9f015e64e57e852f6c004859b9"
23
24S = "${WORKDIR}/freetype-${PV}"
25
26inherit autotools pkgconfig binconfig
27
28LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
29EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
30EXTRA_OEMAKE_virtclass-native = ""
31EXTRA_OECONF = "--without-zlib --without-bzip2"
32
33do_configure() {
34 cd builds/unix
35 libtoolize --force --copy
36 aclocal -I .
37 gnu-configize --force
38 autoconf
39 cd ${S}
40 oe_runconf
41}
42
43do_configure_virtclass-native() {
44 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
45 oe_runconf
46}
47
48do_compile_prepend() {
49 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
50}
51
52FILES_${PN} = "${libdir}/lib*${SOLIBS}"
53FILES_${PN}-dev += "${bindir}"
54
55BBCLASSEXTEND = "native"
56