summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.4.8.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2011-12-26 23:33:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:23 +0000
commit31cb9dbf550091ee07dead83d2ef54f3e326789e (patch)
treee81c3bba25edee3674232cc41ea3fd68c6594499 /meta/recipes-graphics/freetype/freetype_2.4.8.bb
parent2d45549a3b3e38e12028c5d81d293495b63e3af1 (diff)
downloadpoky-31cb9dbf550091ee07dead83d2ef54f3e326789e.tar.gz
freetype: upgrade to 2.4.8
(From OE-Core rev: 172a9562aa1df224cf8e60f7d73c4840db96edb5) Signed-off-by: Shane Wang <shane.wang@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.4.8.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.4.8.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.4.8.bb b/meta/recipes-graphics/freetype/freetype_2.4.8.bb
new file mode 100644
index 0000000000..bce01cf216
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.4.8.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9LICENSE = "FreeType | GPLv2+"
10LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=28d5381b1bef2649c59f20c20bae4f39 \
11 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14SECTION = "libs"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
19 file://no-hardcode.patch"
20
21SRC_URI[md5sum] = "dbf2caca1d3afd410a29217a9809d397"
22SRC_URI[sha256sum] = "a9eb7da3875fcb2f022a9c280c01b94ae45ac83d8102838c05dce1277948fb71"
23
24S = "${WORKDIR}/freetype-${PV}"
25
26inherit autotools pkgconfig binconfig
27
28LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
29EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
30EXTRA_OEMAKE_virtclass-native = ""
31EXTRA_OECONF = "--without-zlib --without-bzip2"
32
33do_configure() {
34 cd builds/unix
35 libtoolize --force --copy
36 aclocal -I .
37 gnu-configize --force
38 autoconf
39 cd ${S}
40 oe_runconf
41}
42
43do_configure_virtclass-native() {
44 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
45 oe_runconf
46}
47
48do_compile_prepend() {
49 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
50}
51
52FILES_${PN} = "${libdir}/lib*${SOLIBS}"
53FILES_${PN}-dev += "${bindir}"
54
55BBCLASSEXTEND = "native"
56