summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.4.6.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-08-16 16:17:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-17 15:14:57 +0100
commit8c9add68f4b05a7c21310881e71ce0cff4d656a7 (patch)
treeb037494c56af5825739b36cfe09098354c3ffefd /meta/recipes-graphics/freetype/freetype_2.4.6.bb
parentce6a08ce956eaa4bbf14885044d2772114235b00 (diff)
downloadpoky-8c9add68f4b05a7c21310881e71ce0cff4d656a7.tar.gz
freetype: upgrade from 2.4.4 to 2.4.6
freetype-2.4.6/docs/LICENSE.TXT changed a little to describe more clearly the compatibility about FreeTypeLicense and GPLv2+, but the actual license remains unchanged: it's still LICENSE = "FreeTypeLicense | GPLv2+". (From OE-Core rev: 06e0d50a936c01d4f02e7208b7e3784947436462) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.4.6.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.4.6.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.4.6.bb b/meta/recipes-graphics/freetype/freetype_2.4.6.bb
new file mode 100644
index 0000000000..8150dd41eb
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.4.6.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9LICENSE = "FreeTypeLicense | GPLv2+"
10LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=28d5381b1bef2649c59f20c20bae4f39 \
11 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14SECTION = "libs"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
19 file://no-hardcode.patch"
20
21SRC_URI[md5sum] = "5e6510613f612809d2d7862592b92ab7"
22SRC_URI[sha256sum] = "24a4a57f3a6859887e91f90f93f754cfc7bf9ab9246a3a696435a0c6a7a1e92a"
23
24S = "${WORKDIR}/freetype-${PV}"
25
26inherit autotools pkgconfig binconfig
27
28LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
29EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
30EXTRA_OEMAKE_virtclass-native = ""
31EXTRA_OECONF = "--without-zlib"
32
33do_configure() {
34 cd builds/unix
35 libtoolize --force --copy
36 aclocal -I .
37 gnu-configize --force
38 autoconf
39 cd ${S}
40 oe_runconf
41}
42
43do_configure_virtclass-native() {
44 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
45 oe_runconf
46}
47
48do_compile_prepend() {
49 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
50}
51
52FILES_${PN} = "${libdir}/lib*${SOLIBS}"
53FILES_${PN}-dev += "${bindir}"
54
55BBCLASSEXTEND = "native"
56