summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.4.3.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-01-27 19:09:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 16:49:13 +0000
commit0b60fa1d15b40b6faf7328710df1052228662e2b (patch)
treec23337ad8c66c6ef19f3158e092c98cadb2468d4 /meta/recipes-graphics/freetype/freetype_2.4.3.bb
parentaf5cdac730168d5f61581ae849982951ec8b3395 (diff)
downloadpoky-0b60fa1d15b40b6faf7328710df1052228662e2b.tar.gz
freetype: upgrade from 2.4.3 to 2.4.4
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.4.3.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.4.3.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.4.3.bb b/meta/recipes-graphics/freetype/freetype_2.4.3.bb
deleted file mode 100644
index 63061fbc17..0000000000
--- a/meta/recipes-graphics/freetype/freetype_2.4.3.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9LICENSE = "FreeTypeLicense | GPLv2+"
10LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=8bc1a580aeb518100d00a2dd29e68edf \
11 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12 file://docs/GPL.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14SECTION = "libs"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
19 file://no-hardcode.patch"
20
21SRC_URI[md5sum] = "75ac7082bde7b3805dc5d6bc806fa045"
22SRC_URI[sha256sum] = "b4e626db62fd1b4549ff5d57f5eca3a41631fd6066adf8a31c11879b51249afc"
23
24S = "${WORKDIR}/freetype-${PV}"
25
26inherit autotools pkgconfig binconfig
27
28LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
29EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
30EXTRA_OEMAKE_virtclass-native = ""
31EXTRA_OECONF = "--without-zlib"
32
33do_configure() {
34 cd builds/unix
35 libtoolize --force --copy
36 aclocal -I .
37 gnu-configize --force
38 autoconf
39 cd ${S}
40 oe_runconf
41}
42
43do_configure_virtclass-native() {
44 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
45 oe_runconf
46}
47
48do_compile_prepend() {
49 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
50}
51
52FILES_${PN} = "${libdir}/lib*${SOLIBS}"
53FILES_${PN}-dev += "${bindir}"
54
55BBCLASSEXTEND = "native"
56