summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.10.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-07-19 22:16:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-22 17:31:03 +0100
commitfa103d3481c838ab98379ea1adfde6f61b8b7664 (patch)
treed663046bb45c33ae72908a8203c6242d72ef8cbc /meta/recipes-graphics/freetype/freetype_2.10.1.bb
parent82b5ed6acf2c1755eadc7901c0aa2952d7f9adbc (diff)
downloadpoky-fa103d3481c838ab98379ea1adfde6f61b8b7664.tar.gz
freetype: upgrade to 2.10.1
Also switch SRC_URI to the nongnu mirrors as they're more reliable than Sourceforge. (From OE-Core rev: 18875698e182d5eb5a9bc1f95abdc2348f66cedc) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.10.1.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.10.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.10.1.bb b/meta/recipes-graphics/freetype/freetype_2.10.1.bb
new file mode 100644
index 0000000000..b179a0ed47
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.10.1.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
11LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
12 file://docs/FTL.TXT;md5=9f37b4e6afa3fef9dba8932b16bd3f97 \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
15SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BP}.tar.xz \
16 file://use-right-libtool.patch \
17 "
18SRC_URI[md5sum] = "bd42e75127f8431923679480efb5ba8f"
19SRC_URI[sha256sum] = "16dbfa488a21fe827dc27eaf708f42f7aa3bb997d745d31a19781628c36ba26f"
20
21UPSTREAM_CHECK_REGEX = "freetype-(?P<pver>\d+(\.\d+)+)"
22
23inherit autotools pkgconfig multilib_header
24
25# Adapt autotools to work with the minimal autoconf usage in freetype
26AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
27CONFIGURE_SCRIPT = "${S}/configure"
28EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
29
30PACKAGECONFIG ??= "zlib"
31
32PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
33# harfbuzz results in a circular dependency so enabling is non-trivial
34PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
35PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
36PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
37PACKAGECONFIG[freetypeconfig] = "--enable-freetype-config=yes,--enable-freetype-config=no,"
38
39EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
40
41TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
42
43do_install_append() {
44 oe_multilib_header freetype2/freetype/config/ftconfig.h
45}
46
47BBCLASSEXTEND = "native nativesdk"