diff options
author | Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> | 2019-04-06 15:36:20 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-04-12 14:05:38 +0100 |
commit | 6fcfe3848246bd36021c3329701b83fb994a01fd (patch) | |
tree | 072bc99b66cc21b6ac889c443aca00c802d7ffde /meta/recipes-graphics/fontconfig/fontconfig_2.13.1.bb | |
parent | 8a2435b3e0c22c73752071181c7d9b6a1a29207e (diff) | |
download | poky-6fcfe3848246bd36021c3329701b83fb994a01fd.tar.gz |
fontconfig: update to 2.13.1
Removed patches were upstreammed.
License position in fccache.c was changed since code segment was moved
in the file.
Package requires uuid, therefore dependency on util-linux was added.
inherit gettext was added to fix:
...%s required but not in DEPENDS for file %s. Missing inherit gettext?
(From OE-Core rev: a03936d1bfd01afa320e289e3ba6e7a24979f196)
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.13.1.bb')
-rw-r--r-- | meta/recipes-graphics/fontconfig/fontconfig_2.13.1.bb | 70 |
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.13.1.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.13.1.bb new file mode 100644 index 0000000000..d0da419ce0 --- /dev/null +++ b/meta/recipes-graphics/fontconfig/fontconfig_2.13.1.bb | |||
@@ -0,0 +1,70 @@ | |||
1 | SUMMARY = "Generic font configuration library" | ||
2 | DESCRIPTION = "Fontconfig is a font configuration and customization library, which \ | ||
3 | does not depend on the X Window System. It is designed to locate \ | ||
4 | fonts within the system and select them according to requirements \ | ||
5 | specified by applications. \ | ||
6 | Fontconfig is not a rasterization library, nor does it impose a \ | ||
7 | particular rasterization library on the application. The X-specific \ | ||
8 | library 'Xft' uses fontconfig along with freetype to specify and \ | ||
9 | rasterize fonts." | ||
10 | |||
11 | HOMEPAGE = "http://www.fontconfig.org" | ||
12 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig" | ||
13 | |||
14 | LICENSE = "MIT-style & MIT & PD" | ||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \ | ||
16 | file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \ | ||
17 | file://src/fccache.c;beginline=1671;endline=1686;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f" | ||
18 | |||
19 | SECTION = "libs" | ||
20 | |||
21 | DEPENDS = "expat freetype zlib gperf-native util-linux" | ||
22 | |||
23 | SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \ | ||
24 | file://revert-static-pkgconfig.patch \ | ||
25 | " | ||
26 | |||
27 | SRC_URI[md5sum] = "690c6cb840a92fa8908cdf462d19ec66" | ||
28 | SRC_URI[sha256sum] = "9f0d852b39d75fc655f9f53850eb32555394f36104a044bb2b2fc9e66dbbfa7f" | ||
29 | |||
30 | UPSTREAM_CHECK_REGEX = "fontconfig-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" | ||
31 | |||
32 | do_configure_prepend() { | ||
33 | # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280 | ||
34 | rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf | ||
35 | } | ||
36 | |||
37 | do_install_append_class-target() { | ||
38 | # duplicate fc-cache for postinstall script | ||
39 | mkdir -p ${D}${libexecdir} | ||
40 | ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache | ||
41 | } | ||
42 | |||
43 | do_install_append_class-nativesdk() { | ||
44 | # duplicate fc-cache for postinstall script | ||
45 | mkdir -p ${D}${libexecdir} | ||
46 | ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache | ||
47 | } | ||
48 | |||
49 | PACKAGES =+ "fontconfig-utils" | ||
50 | FILES_${PN} =+ "${datadir}/xml/*" | ||
51 | FILES_${PN}-dev += "${datadir}/gettext/*" | ||
52 | FILES_fontconfig-utils = "${bindir}/* ${libexecdir}/*" | ||
53 | |||
54 | # Work around past breakage in debian.bbclass | ||
55 | RPROVIDES_fontconfig-utils = "libfontconfig-utils" | ||
56 | RREPLACES_fontconfig-utils = "libfontconfig-utils" | ||
57 | RCONFLICTS_fontconfig-utils = "libfontconfig-utils" | ||
58 | DEBIAN_NOAUTONAME_fontconfig-utils = "1" | ||
59 | |||
60 | inherit autotools pkgconfig relative_symlinks gettext | ||
61 | |||
62 | FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig" | ||
63 | |||
64 | # comma separated list of additional directories | ||
65 | # /usr/share/fonts is already included by default (you can change it with --with-default-fonts) | ||
66 | FONTCONFIG_FONT_DIRS ?= "no" | ||
67 | |||
68 | EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}" | ||
69 | |||
70 | BBCLASSEXTEND = "native nativesdk" | ||