diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-03-03 10:59:25 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-03-05 10:22:56 -0800 |
commit | 06f2f8ce0a3093973ca54b48f542f8485b666079 (patch) | |
tree | dbcfa5c491eb2e5d237aa539cb7c6e77dc07dd6f /meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb | |
parent | d01dadfb87cfd2284b3e849d35a35fe5df0239c4 (diff) | |
download | poky-06f2f8ce0a3093973ca54b48f542f8485b666079.tar.gz |
meta: Convert getVar/getVarFlag(xxx, 1) -> (xxx, True)
Using "1" with getVar is bad coding style and "True" is preferred.
This patch is a sed over the meta directory of the form:
sed \
-e 's:\(\.getVar([^,()]*, \)1 *):\1True):g' \
-e 's:\(\.getVarFlag([^,()]*, [^,()]*, \)1 *):\1True):g' \
-i `grep -ril getVar *`
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb')
-rw-r--r-- | meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb b/meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb index 0e213909e3..a2fd409c42 100644 --- a/meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb +++ b/meta/recipes-graphics/fontconfig/fontconfig-native_2.8.0.bb | |||
@@ -3,7 +3,7 @@ inherit native | |||
3 | DEPENDS = "freetype-native expat-native zlib-native" | 3 | DEPENDS = "freetype-native expat-native zlib-native" |
4 | 4 | ||
5 | EXTRA_OEMAKE = "" | 5 | EXTRA_OEMAKE = "" |
6 | EXTRA_OECONF = "${@[' --disable-docs',' --disable-docs --with-freetype-config=%s/freetype-config' % d.getVar('STAGING_BINDIR', 1)][os.path.isfile('%s/freetype-config' % d.getVar('STAGING_BINDIR', 1))]}" | 6 | EXTRA_OECONF = "${@[' --disable-docs',' --disable-docs --with-freetype-config=%s/freetype-config' % d.getVar('STAGING_BINDIR', True)][os.path.isfile('%s/freetype-config' % d.getVar('STAGING_BINDIR', True))]}" |
7 | 7 | ||
8 | do_install_append () { | 8 | do_install_append () { |
9 | install -d ${D}${bindir}/ | 9 | install -d ${D}${bindir}/ |