summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm/libdrm_2.4.92.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-05-21 18:50:50 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:07:15 +0100
commit9751db80a31b7c578bb4c8f62c1f449450823b36 (patch)
tree1d0ef9a7c410d038548809fc48f07e890cbfffb6 /meta/recipes-graphics/drm/libdrm_2.4.92.bb
parentd76f4f7a697843be6e4235fa5e4adaa22b0138fc (diff)
downloadpoky-9751db80a31b7c578bb4c8f62c1f449450823b36.tar.gz
libdrm: upgrade 2.4.91 -> 2.4.92
Daniel Stone (3): drm/atomic: Refuse to add invalid objects to requests headers: Sync with drm-next headers: Update README Dylan Baker (1): meson: don't use compiler.has_header Emil Velikov (1): Revert "libdrm: intel/Android.mk: Filter libdrm_intel library requirements on x86/x86_64" Eric Engestrom (13): freedreno: add missing symbols to symbol-check meson: use pkg-config to detect libatomic_ops meson: make it easy to add headers to check meson: detect alloca.h meson,configure: always define HAVE_OPEN_MEMSTREAM meson,configure: always define HAVE_VISIBILITY meson,configure: always define UDEV meson: replace `if(compiles) have=true` with `have=compiles` meson,configure: include config.h automatically meson: drop unneeded dependency to libudev meson: move line to allow using `config` earlier meson: drop unnecessary variable xf86drmMode: merge successive mutually-exclusive #ifs Gowtham Tammana (1): omap: add Android build support Inki Dae (1): tests: fix memory leak issue James Zhu (1): tests/amdgpu: add vce mv tests support and sets John Stultz (3): libdrm: intel/Android.mk: Filter libdrm_intel library requirements on x86/x86_64 libdrm: Use readdir instead of readdir_r to avoid build warnings libdrm: gralloc_handle.h: Fix build issue with Android Marek Olšák (1): Revert "amdgpu:support 16 ibs per submit for PAL/SRIOV" Matt Atwood (1): Intel: Add a Kaby Lake PCI ID Michel Dänzer (1): amdgpu: Deinitialize vamgr_high{,_32} Paulo Zanoni (1): intel: add support for ICL 11 Qiang Yu (1): amdgpu:support 16 ibs per submit for PAL/SRIOV Rex Zhu (1): headers: sync up amdgpu_drm.h with drm-next Rob Clark (2): freedreno: add fd_pipe refcounting bump version for release Rodrigo Vivi (1): intel/intel_chipset.h: Sync Cannonlake IDs. Sabre Shao (1): drm/amdgpu: Remove IB count checking Satyajit (1): libdrm: amdgpu: Adding DRM_RDWR flag in amdgpu_bo_export Seung-Woo Kim (1): tests/exynos: remove dead condition Stefan Schake (1): android: Add missing include exports Tomasz Figa (1): intel: Do not use libpciaccess on Android Xiaojie Yuan (1): amdgpu: enlarge the maximum number of cards supported (From OE-Core rev: 805c362871b1a03fbee941b628f2e8aca0f4bb51) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/drm/libdrm_2.4.92.bb')
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.92.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.92.bb b/meta/recipes-graphics/drm/libdrm_2.4.92.bb
new file mode 100644
index 0000000000..8f59452a49
--- /dev/null
+++ b/meta/recipes-graphics/drm/libdrm_2.4.92.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Userspace interface to the kernel DRM services"
2DESCRIPTION = "The runtime library for accessing the kernel DRM services. DRM \
3stands for \"Direct Rendering Manager\", which is the kernel portion of the \
4\"Direct Rendering Infrastructure\" (DRI). DRI is required for many hardware \
5accelerated OpenGL drivers."
6HOMEPAGE = "http://dri.freedesktop.org"
7SECTION = "x11/base"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
10PROVIDES = "drm"
11DEPENDS = "libpthread-stubs libpciaccess"
12
13SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
14 file://installtests.patch \
15 file://fix_O_CLOEXEC_undeclared.patch \
16 file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \
17 "
18
19SRC_URI[md5sum] = "f9b00d985f82d0be6ecc20c799acc89e"
20SRC_URI[sha256sum] = "e9e48fdb4de139dc4d9880aa1473158a16ff6aff63d14341367bd30a51ff39fa"
21
22inherit autotools pkgconfig manpages
23
24EXTRA_OECONF += "--disable-cairo-tests \
25 --without-cunit \
26 --enable-omap-experimental-api \
27 --enable-etnaviv-experimental-api \
28 --enable-install-test-programs \
29 --disable-valgrind \
30 "
31PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
32
33ALLOW_EMPTY_${PN}-drivers = "1"
34PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \
35 ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno ${PN}-amdgpu \
36 ${PN}-etnaviv"
37
38RRECOMMENDS_${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \
39 ${PN}-exynos ${PN}-freedreno ${PN}-amdgpu \
40 ${PN}-etnaviv"
41
42FILES_${PN}-tests = "${bindir}/*"
43FILES_${PN}-radeon = "${libdir}/libdrm_radeon.so.*"
44FILES_${PN}-nouveau = "${libdir}/libdrm_nouveau.so.*"
45FILES_${PN}-omap = "${libdir}/libdrm_omap.so.*"
46FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*"
47FILES_${PN}-exynos = "${libdir}/libdrm_exynos.so.*"
48FILES_${PN}-kms = "${libdir}/libkms*.so.*"
49FILES_${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*"
50FILES_${PN}-amdgpu = "${libdir}/libdrm_amdgpu.so.*"
51FILES_${PN}-etnaviv = "${libdir}/libdrm_etnaviv.so.*"