summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/librsvg/librsvg_2.40.15.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-05-03 06:33:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-11 10:33:39 +0100
commit26bf0e9bf20358bd81a0ff9e57f383fc9ba5ff09 (patch)
treeb8e47f0d000c69b5856489510bbcee6a76dcb4b7 /meta/recipes-gnome/librsvg/librsvg_2.40.15.bb
parent01f60522468bad2fd4b765e262a4c614ca11dfcc (diff)
downloadpoky-26bf0e9bf20358bd81a0ff9e57f383fc9ba5ff09.tar.gz
librsvg: Security fixes via update to 2.40.15
CVE-2016-4347 librsvg2: DoS parsing SVGs with circular definitions in certain rsvg_cairo_*() functions CVE-2016-4348 librsvg2: DoS parsing SVGs with circular definitions _rsvg_css_normalize_font_size() function (From OE-Core rev: 76f061c91fd00370e33bfc3d45ff98d8b3f63c41) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/librsvg/librsvg_2.40.15.bb')
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.40.15.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.40.15.bb b/meta/recipes-gnome/librsvg/librsvg_2.40.15.bb
new file mode 100644
index 0000000000..caa6a24c9e
--- /dev/null
+++ b/meta/recipes-gnome/librsvg/librsvg_2.40.15.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Library for rendering SVG files"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/librsvg/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://rsvg.h;beginline=3;endline=24;md5=20b4113c4909bbf0d67e006778302bc6"
8
9SECTION = "x11/utils"
10DEPENDS = "cairo gdk-pixbuf glib-2.0 libcroco libxml2 pango"
11BBCLASSEXTEND = "native"
12
13inherit autotools pkgconfig gnomebase gtk-doc pixbufcache upstream-version-is-even gobject-introspection
14
15SRC_URI += "file://gtk-option.patch"
16
17SRC_URI[archive.md5sum] = "3a66ab5b4fe1fb43b471708e4ff39a0e"
18SRC_URI[archive.sha256sum] = "d9cac4a123eec6e553a26e120979bab7425def9ae7ce7c079eba5e4a45db05f4"
19
20CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
21
22# The older ld (2.22) on the host (Centos 6.5) doesn't have the
23# -Bsymbolic-functions option, we can disable it for native.
24EXTRA_OECONF_append_class-native = " --enable-Bsymbolic=auto"
25
26PACKAGECONFIG ??= "gdkpixbuf"
27# The gdk-pixbuf loader
28PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
29# GTK+ test application (rsvg-view)
30PACKAGECONFIG[gtk] = "--with-gtk3,--without-gtk3,gtk+3"
31
32do_install_append() {
33 # Loadable modules don't need .a or .la on Linux
34 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
35}
36
37PACKAGES =+ "librsvg-gtk rsvg"
38FILES_rsvg = "${bindir}/rsvg* \
39 ${datadir}/pixmaps/svg-viewer.svg \
40 ${datadir}/themes"
41FILES_librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so"
42
43PIXBUF_PACKAGES = "librsvg-gtk"
44
45PIXBUFCACHE_SYSROOT_DEPS_append_class-native = " harfbuzz-native:do_populate_sysroot_setscene pango-native:do_populate_sysroot_setscene icu-native:do_populate_sysroot_setscene"