summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-12-19 19:52:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 08:14:25 +0000
commit9e64b6d96c0434d91150c3b4829046e6d70b0e00 (patch)
tree7f47b0697fcff0c2244841308df33f7d6ce73159 /meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
parentdb8bf52277c1596e0703cee21ff52cad04365eb7 (diff)
downloadpoky-9e64b6d96c0434d91150c3b4829046e6d70b0e00.tar.gz
gtk+: upgrade to 2.24.25
Remove patches that are no longer needed: * GtkButton-do-no-prelight: merged upstream * Duplicate-the-exec-string: upstream decided this behaviour is incorrect * cellrenderer-cairo: Cairo isn't the performance bottleneck it once was, drop * configure-nm: resolved upstrea * configurefix.patch: not applied * run-iconcache: not needed when building tarballs, and if gtk-update-icon-cache is needed at build time (e.g. user is customising default icon theme) then they can add a dependency on gtk-update-icon-cache-native. Also remove mention of patches that have been commented out for a long time. (From OE-Core rev: 9299b5d2e5f82cf0e3f66ca49dedbe2c8b18bb44) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gtk+_2.24.25.bb')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.24.25.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb b/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
new file mode 100644
index 0000000000..ada79567e7
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+_2.24.25.bb
@@ -0,0 +1,33 @@
1require gtk+.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
4 file://gtk/gtk.h;endline=27;md5=c59e0b4490dd135a5726ebf851f9b17f \
5 file://gdk/gdk.h;endline=27;md5=07db285ec208fb3e0bf7d861b0614202 \
6 file://tests/testgtk.c;endline=27;md5=262db5db5f776f9863e56df31423e24c"
7SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-${PV}.tar.xz \
8 file://xsettings.patch \
9 file://hardcoded_libtool.patch \
10 file://toggle-font.diff;striplevel=0 \
11 file://doc-fixes.patch \
12 "
13
14SRC_URI[md5sum] = "612350704dd3aacb95355a4981930c6f"
15SRC_URI[sha256sum] = "38af1020cb8ff3d10dda2c8807f11e92af9d2fa4045de61c62eedb7fbc7ea5b3"
16
17EXTRA_OECONF = "--enable-xkb --disable-glibtest --disable-cups --disable-xinerama"
18
19LIBV = "2.10.0"
20
21PACKAGES_DYNAMIC += "^gtk-immodule-.* ^gtk-printbackend-.*"
22
23python populate_packages_prepend () {
24 gtk_libdir = d.expand('${libdir}/gtk-2.0/${LIBV}')
25 immodules_root = os.path.join(gtk_libdir, 'immodules')
26 printmodules_root = os.path.join(gtk_libdir, 'printbackends');
27
28 d.setVar('GTKIMMODULES_PACKAGES', ' '.join(do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s')))
29 do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
30
31 if (d.getVar('DEBIAN_NAMES', True)):
32 d.setVar('PKG_${PN}', '${MLPREFIX}libgtk-2.0')
33}