summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+/gtk+_2.22.1.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-11-22 14:26:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-27 21:52:01 +0000
commit7c9c78bebd074d72270adaa8baed860bf554ad82 (patch)
treee28a5c7033d9ee973c96674e733c592f9724be0a /meta/recipes-gnome/gtk+/gtk+_2.22.1.bb
parent8a6e8623b43a5b38546e0a8c96f473dba9b31eee (diff)
downloadpoky-7c9c78bebd074d72270adaa8baed860bf554ad82.tar.gz
gtk+: Update to 2.22.1
Remove disable-gio-png-sniff-test.diff as it alreay in upstream. gdk-pixbuf in gtk+ is separated as another stand-alone package, so remove it. In future need only pick up stable version(even number like 2.20.x, 2.22.x). Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gtk+_2.22.1.bb')
-rw-r--r--meta/recipes-gnome/gtk+/gtk+_2.22.1.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk+_2.22.1.bb b/meta/recipes-gnome/gtk+/gtk+_2.22.1.bb
new file mode 100644
index 0000000000..35aa883251
--- /dev/null
+++ b/meta/recipes-gnome/gtk+/gtk+_2.22.1.bb
@@ -0,0 +1,57 @@
1require gtk+.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
4 file://gtk/gtk.h;endline=27;md5=c59e0b4490dd135a5726ebf851f9b17f \
5 file://gdk/gdk.h;endline=27;md5=07db285ec208fb3e0bf7d861b0614202 \
6 file://tests/testgtk.c;endline=27;md5=262db5db5f776f9863e56df31423e24c"
7PR = "r0"
8
9SRC_URI = "http://download.gnome.org/sources/gtk+/2.22/gtk+-${PV}.tar.bz2 \
10 file://xsettings.patch;patch=1 \
11 file://run-iconcache.patch;patch=1 \
12 file://hardcoded_libtool.patch;patch=1 \
13 file://no-demos.patch;patch=1 \
14 file://cellrenderer-cairo.patch;patch=1;pnum=0 \
15 file://toggle-font.diff;patch=1;pnum=0 \
16 file://0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch;patch=1 \
17# TO MERGE
18# file://entry-cairo.patch;patch=1;pnum=0 \
19# file://filesystem-volumes.patch;patch=1 \
20# file://filechooser-props.patch;patch=1 \
21# file://filechooser-default.patch;patch=1 \
22# file://filechooser-sizefix.patch;patch=1 \
23# temporary
24# file://gtklabel-resize-patch;patch=1 \
25# file://menu-deactivate.patch;patch=1 \
26# file://combo-arrow-size.patch;patch=1;pnum=0 \
27# file://configurefix.patch;patch=1 \
28 "
29
30SRC_URI[md5sum] = "fdce46ba354c155230b7d4090b17f7d9"
31SRC_URI[sha256sum] = "965bc124f0d25087c4cb2a64cbfd7e4f896e05be8d560fbba68dd8685ba24d07"
32
33EXTRA_OECONF = "--without-libtiff --without-libjasper --enable-xkb --disable-glibtest --disable-cups"
34
35LIBV = "2.10.0"
36
37PACKAGES_DYNAMIC += "gtk-immodule-* gtk-printbackend-*"
38
39#-fomit-frame-pointer in default FULL_OPTIMIZATION will cause matchbox-panel segfault on atom-pc & emenlow
40FULL_OPTIMIZATION_emenlow = "-fexpensive-optimizations -frename-registers -O2 -ggdb -feliminate-unused-debug-types"
41FULL_OPTIMIZATION_atom-pc = "-fexpensive-optimizations -frename-registers -O2 -ggdb -feliminate-unused-debug-types"
42
43python populate_packages_prepend () {
44 import os.path
45
46 prologue = bb.data.getVar("postinst_prologue", d, 1)
47
48 gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
49 immodules_root = os.path.join(gtk_libdir, 'immodules')
50 printmodules_root = os.path.join(gtk_libdir, 'printbackends');
51
52 do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', prologue + 'gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules')
53 do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
54
55 if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
56 bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
57}