summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-08-22 15:23:09 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-23 17:44:41 +0100
commitc0dcc5d44cdcc2fa0956613f250829adab122593 (patch)
tree6c0cb90a4737f807b19f47e92261b1d557773183 /meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb
parent69d8707bd20fef19f79c7eb162fd228d187a6486 (diff)
downloadpoky-c0dcc5d44cdcc2fa0956613f250829adab122593.tar.gz
gnome-themes-standard: Upgrade 3.18.0 -> 3.20.2
(From OE-Core rev: 1d0dcb0e8bc7b5f11b8249053008d9860a40dc61) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb')
-rw-r--r--meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb b/meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb
new file mode 100644
index 0000000000..c98d8702c1
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gnome-themes-standard_3.20.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9inherit autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even distro_features_check
10
11ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
12
13DEPENDS += "intltool-native gtk+"
14
15MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
17 "
18
19SRC_URI[md5sum] = "adc3b1d57330561fea524842d0c0b485"
20SRC_URI[sha256sum] = "9d0d9c4b2c9f9008301c3c1878ebb95859a735b7fd4a6a518802b9637e4a7915"
21
22EXTRA_OECONF = "--disable-gtk3-engine"
23
24do_install_append() {
25 # Only building Adwaita, remove highcontrast files
26 rm -rf ${D}${prefix}/share/themes/HighContrast \
27 ${D}${prefix}/share/icons
28}
29
30# There could be gnome-theme-highcontrast as well but that requires
31# gtk+3 and includes lots of icons (is also broken with B != S).
32PACKAGES += "gnome-theme-adwaita \
33 gnome-theme-adwaita-dbg \
34 gnome-theme-adwaita-dev"
35
36FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
37 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
38FILES_gnome-theme-adwaita-dev = "${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la"
39FILES_gnome-theme-adwaita-dbg = "${libdir}/gtk-2.0/2.10.0/engines/.debug/libadwaita.so"