summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf_3.2.3.bb
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2011-11-01 14:46:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-10 11:37:11 +0000
commitd4d29f7e58b0e86c6ac91d05730e319fe1706aa2 (patch)
tree8bc7e520819e32a4f6b58fa8d4d55b9a52c364d9 /meta/recipes-gnome/gnome/gconf_3.2.3.bb
parent1ab3d1b5489eeaff78add14f4886269c690a3d46 (diff)
downloadpoky-d4d29f7e58b0e86c6ac91d05730e319fe1706aa2.tar.gz
gconf: add upstream GNOME gconf 3.2.3 and drop gconf-dbus
The D-Bus backend has been integrated into upstream GConf so we can switch to upstream and drop gconf-dbus. I've gone for a release in the 3.2 series as we disable Gtk+, and therefore are not impacted by the gtk+3 changes, and the D-Bus backend was unstable before this release. (From OE-Core rev: f952b1bc8a4f307e2e2f3941f50becd72d88421d) Signed-off-by: Joshua Lock <josh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf_3.2.3.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
new file mode 100644
index 0000000000..0e06cb5e87
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "GNOME configuration system"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native polkit"
7
8inherit gnomebase
9
10SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.bz2;name=archive \
11 file://nointro.patch"
12
13SRC_URI[archive.md5sum] = "f80329173cd9d134ad07e36002dd2a15"
14SRC_URI[archive.sha256sum] = "52008a82a847527877d9e1e549a351c86cc53cada4733b8a70a1123925d6aff4"
15
16S = "${WORKDIR}/GConf-${PV}"
17
18EXTRA_OECONF = "--disable-gtk-doc --disable-gtk --enable-shared --disable-static --enable-debug=yes --disable-introspection --disable-orbit --with-openldap=no"
19
20do_configure_prepend () {
21 touch gtk-doc.make
22}
23
24do_install_append() {
25 # this directory need to be created to avoid an Error 256 at gdm launch
26 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
27
28 # this stuff is unusable
29 rm ${D}${libdir}/GConf/*/*.*a
30 rm ${D}${libdir}/gio/*/*.*a
31}
32
33RDEPENDS_${PN} += "dbus-x11"
34FILES_${PN} += "${libdir}/GConf/* \
35 ${libdir}/gio/*/*.so \
36 ${datadir}/polkit* \
37 ${datadir}/dbus-1/services/*.service \
38 ${datadir}/dbus-1/system-services/*.service \
39 "
40FILES_${PN}-dbg += "${libdir}/*/*/.debug"
41FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
42
43BBCLASSEXTEND = "native"