summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-01-21 15:29:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-21 23:25:53 +0000
commite5674ee26ed44917e9c241c5e45f86a617b6ee56 (patch)
treeab375b444417c644b461a49e418d1e70dc490c2f /meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb
parent85335647a316230ad78520955ba738f08c334659 (diff)
downloadpoky-e5674ee26ed44917e9c241c5e45f86a617b6ee56.tar.gz
adwaita-icon-theme: add version 3.34.3 backmaster-test
Newer versions of adwaita-icon-theme can't work well with librsvg 2.40. Boot up the core-image-sato image, and start "Media Player", most of the icons are not showed properly. The source code of librsvg has been adapted to rust, so it is impossible to update librsvg in oe core for now. Then add adwaita-icon-theme 3.34.3 back and set as preferred version. Duplicate one patch as well to fix patch fuzz issue. Ref: 1. https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/issues/84 2. https://people.gnome.org/~federico/blog/do-not-use-librsvg-2.40.x.html (From OE-Core rev: c3e2f819640f73893b8688c18a2b12fc2c5f9ed9) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb')
-rw-r--r--meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb
new file mode 100644
index 0000000000..6cde6fffa3
--- /dev/null
+++ b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.34.3.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GTK+ icon theme"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
3BUGTRACKER = "https://gitlab.gnome.org/GNOME/adwaita-icon-theme/issues"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-3.0 | CC-BY-SA-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c \
8 file://COPYING_CCBYSA3;md5=96143d33de3a79321b1006c4e8ed07e7 \
9 file://COPYING_LGPL;md5=e6a600fd5e1d9cbde2d983680233ad02"
10
11inherit allarch autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even
12
13MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
14SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
15 file://0001-Don-t-use-AC_CANONICAL_HOST-3.34.3.patch \
16 file://0001-Run-installation-commands-as-shell-jobs.patch \
17 "
18
19SRC_URI[md5sum] = "9aea4ad9bc002aacad155ee0748b357f"
20SRC_URI[sha256sum] = "e7c2d8c259125d5f35ec09522b88c8fe7ecf625224ab0811213ef0a95d90b908"
21
22DEPENDS += "librsvg-native"
23
24PACKAGES = "${PN}-cursors ${PN}-symbolic-hires ${PN}-symbolic ${PN}-hires ${PN}"
25
26RREPLACES_${PN} = "gnome-icon-theme"
27RCONFLICTS_${PN} = "gnome-icon-theme"
28RPROVIDES_${PN} = "gnome-icon-theme"
29
30FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/"
31FILES_${PN}-symbolic-hires = "${prefix}/share/icons/Adwaita/96x96/*/*.symbolic.png \
32 ${prefix}/share/icons/Adwaita/64x64/*/*.symbolic.png \
33 ${prefix}/share/icons/Adwaita/48x48/*/*.symbolic.png \
34 ${prefix}/share/icons/Adwaita/32x32/*/*.symbolic.png"
35FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/16x16/*/*.symbolic.png \
36 ${prefix}/share/icons/Adwaita/24x24/*/*.symbolic.png \
37 ${prefix}/share/icons/Adwaita/scalable/*/*-symbolic*.svg"
38FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/ \
39 ${prefix}/share/icons/Adwaita/512x512/"
40FILES_${PN} = "${prefix}/share/icons/Adwaita/ \
41 ${prefix}/share/pkgconfig/adwaita-icon-theme.pc"
42
43BBCLASSEXTEND = "native nativesdk"