diff options
author | Zhai Edwin <edwin.zhai@intel.com> | 2011-01-30 20:28:58 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-02-01 23:59:39 +0000 |
commit | fd03e8a682c4dc99c25f9df41b920f8174ed6ded (patch) | |
tree | f9dbe183f27d436f4920ec0df9f85861dce85fec /meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb | |
parent | 4e8e8a712891f0e43fe7ad9341da35153d87ebce (diff) | |
download | poky-fd03e8a682c4dc99c25f9df41b920f8174ed6ded.tar.gz |
gdk-pixbuf: Fix the native png load error and remove duplicated recipe
Native gdk-pixbuf-csource failed to load png file as the "loaders.cache" was
not properly set by gdk-pxibuf-query-loaders when install. This patch use the
wrapper script rather than query-loaders binary as required libtool library was
not installed when do_install_append.
Also remove dedicated recipe for gdk-pixbuf-native.
[sgw: Added PACKAGES_DYMAMIC_virtclass-native]
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb')
-rw-r--r-- | meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb | 37 |
1 files changed, 35 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb index 8080719884..78f108a0a2 100644 --- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb | |||
@@ -1,9 +1,34 @@ | |||
1 | require gdk-pixbuf.inc | 1 | DESCRIPTION = "Image loading library for GTK+" |
2 | HOMEPAGE = "http://www.gtk.org/" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
2 | 4 | ||
3 | DEPENDS += "jpeg" | 5 | LICENSE = "LGPLv2" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \ | ||
7 | file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=5066b71daefeff678494fffa3040aba9" | ||
4 | 8 | ||
9 | SECTION = "libs" | ||
10 | PRIORITY = "optional" | ||
11 | |||
12 | DEPENDS = "libpng gettext glib-2.0 jpeg" | ||
5 | PR = "r0" | 13 | PR = "r0" |
6 | 14 | ||
15 | SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gdk-pixbuf/2.22/gdk-pixbuf-${PV}.tar.gz \ | ||
16 | file://hardcoded_libtool.patch;patch=1 \ | ||
17 | file://configure_fix.patch;patch=1 \ | ||
18 | " | ||
19 | |||
20 | SRC_URI[md5sum] = "fcfc854e9aec7dbb2bb3059484d44556" | ||
21 | SRC_URI[sha256sum] = "bbb57364ffba70d64f5fcfe6eda1d67249b3d58844edb06dc0f94d1ad599b4ec" | ||
22 | |||
23 | inherit autotools pkgconfig | ||
24 | |||
25 | LIBV = "2.10.0" | ||
26 | |||
27 | EXTRA_OECONF = "\ | ||
28 | --without-libtiff \ | ||
29 | --with-libpng \ | ||
30 | " | ||
31 | |||
7 | FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \ | 32 | FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \ |
8 | ${libdir}/lib*.so.*" | 33 | ${libdir}/lib*.so.*" |
9 | 34 | ||
@@ -26,6 +51,7 @@ test -x ${bindir}/gtk-update-icon-cache && gtk-update-icon-cache -q ${datadir}/ | |||
26 | } | 51 | } |
27 | 52 | ||
28 | PACKAGES_DYNAMIC += "gdk-pixbuf-loader-*" | 53 | PACKAGES_DYNAMIC += "gdk-pixbuf-loader-*" |
54 | PACKAGES_DYNAMIC_virtclass-native = "" | ||
29 | 55 | ||
30 | python populate_packages_prepend () { | 56 | python populate_packages_prepend () { |
31 | postinst_pixbufloader = bb.data.getVar("postinst_pixbufloader", d, 1) | 57 | postinst_pixbufloader = bb.data.getVar("postinst_pixbufloader", d, 1) |
@@ -35,3 +61,10 @@ python populate_packages_prepend () { | |||
35 | do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', postinst_pixbufloader) | 61 | do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', postinst_pixbufloader) |
36 | } | 62 | } |
37 | 63 | ||
64 | do_install_append_virtclass-native() { | ||
65 | #Use wrapper script rather than binary as required libtool library is not installed now | ||
66 | GDK_PIXBUF_MODULEDIR=${D}${libdir}/gdk-pixbuf-2.0/2.10.0/loaders ${S}/gdk-pixbuf/gdk-pixbuf-query-loaders > ${D}${libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache | ||
67 | sed -i -e 's#${D}##g' ${D}${libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache | ||
68 | find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \; | ||
69 | } | ||
70 | BBCLASSEXTEND = "native" | ||