summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xz/xz_5.2.4.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-17 17:39:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-24 11:52:26 +0100
commit6494ab4ab361a53d739caa47fb48ddac44278494 (patch)
tree3ef10d47c660aa8b2b46062e071197a22f09ae73 /meta/recipes-extended/xz/xz_5.2.4.bb
parent437a5ace77f7aff75e01a3fa5ee08e37b9a5fe0a (diff)
downloadpoky-6494ab4ab361a53d739caa47fb48ddac44278494.tar.gz
xz: upgrade 5.2.3 -> 5.2.4
(From OE-Core rev: 0529b8c88a2cd6c21737023d757f44eebc5a0547) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/xz/xz_5.2.4.bb')
-rw-r--r--meta/recipes-extended/xz/xz_5.2.4.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/xz/xz_5.2.4.bb b/meta/recipes-extended/xz/xz_5.2.4.bb
new file mode 100644
index 0000000000..791746e1cf
--- /dev/null
+++ b/meta/recipes-extended/xz/xz_5.2.4.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Utilities for managing LZMA compressed files"
2HOMEPAGE = "http://tukaani.org/xz/"
3SECTION = "base"
4
5# The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file
6# which is GPLv3 is an m4 macro which isn't shipped in any of our packages,
7# and the LGPL bits are under lib/, which appears to be used for libgnu, which
8# appears to be used for DOS builds. So we're left with GPLv2+ and PD.
9LICENSE = "GPLv2+ & GPL-3.0-with-autoconf-exception & LGPLv2.1+ & PD"
10LICENSE_${PN} = "GPLv2+"
11LICENSE_${PN}-dev = "GPLv2+"
12LICENSE_${PN}-staticdev = "GPLv2+"
13LICENSE_${PN}-doc = "GPLv2+"
14LICENSE_${PN}-dbg = "GPLv2+"
15LICENSE_${PN}-locale = "GPLv2+"
16LICENSE_liblzma = "PD"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \
19 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
20 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \
22 file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \
23 "
24
25SRC_URI = "http://tukaani.org/xz/xz-${PV}.tar.gz"
26SRC_URI[md5sum] = "5ace3264bdd00c65eeec2891346f65e6"
27SRC_URI[sha256sum] = "b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145"
28UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar"
29
30inherit autotools gettext
31
32PACKAGES =+ "liblzma"
33
34FILES_liblzma = "${libdir}/liblzma*${SOLIBS}"
35
36inherit update-alternatives
37ALTERNATIVE_PRIORITY = "100"
38ALTERNATIVE_${PN} = "xz xzcat unxz \
39 lzma lzcat unlzma"
40
41BBCLASSEXTEND = "native nativesdk"
42
43export CONFIG_SHELL="/bin/sh"