summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-05-16 22:39:31 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-21 11:16:38 +0100
commit8c6455b6db3d2c3bf7f52164f55ab275f77e414d (patch)
tree6fe99372139d71d889d0e6aa3e244ba76fcba59e /meta/recipes-extended/xinetd/xinetd_2.3.15.bb
parent73cdebf60df225ee10f2eb215935be3b61e1b831 (diff)
downloadpoky-8c6455b6db3d2c3bf7f52164f55ab275f77e414d.tar.gz
xinetd: Update to 2.3.15
(From OE-Core rev: 48f93e0ade1c534b9af2b84874f9b17e3107c724) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/xinetd/xinetd_2.3.15.bb')
-rw-r--r--meta/recipes-extended/xinetd/xinetd_2.3.15.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/xinetd/xinetd_2.3.15.bb b/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
new file mode 100644
index 0000000000..3d55e99712
--- /dev/null
+++ b/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Highly configurable, modular and secure inetd"
2HOMEPAGE = "http://www.xinetd.org"
3
4# xinetd is a BSD-like license
5# Apple and Gentoo say BSD here.
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
8
9DEPENDS = ""
10PR = "r0"
11
12SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
13 file://xinetd.init \
14 file://xinetd.conf \
15 file://Various-fixes-from-the-previous-maintainer.patch \
16 file://Disable-services-from-inetd.conf-if-a-service-with-t.patch \
17 file://xinetd-should-be-able-to-listen-on-IPv6-even-in-ine.patch \
18 "
19
20SRC_URI[md5sum] = "77358478fd58efa6366accae99b8b04c"
21SRC_URI[sha256sum] = "bf4e060411c75605e4dcbdf2ac57c6bd9e1904470a2f91e01ba31b50a80a5be3"
22
23inherit autotools update-rc.d
24
25INITSCRIPT_NAME = "xinetd"
26INITSCRIPT_PARAMS = "defaults"
27
28EXTRA_OECONF="--disable-nls"
29
30do_configure() {
31 # Looks like configure.in is broken, so we are skipping
32 # rebuilding configure and are just using the shipped one
33 oe_runconf
34}
35
36do_install() {
37 # Same here, the Makefile does some really stupid things,
38 # but since we only want two files why not override
39 # do_install from autotools and doing it ourselfs?
40 install -d "${D}/usr/sbin"
41 install -d "${D}/etc/init.d"
42 install -d "${D}/etc/xinetd.d"
43 install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
44 install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
45 install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
46 install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
47}
48
49CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"