summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-08 09:46:56 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-09 13:14:00 +0100
commit6dd0f14973610925e60c89e32f56c96876f7ffb7 (patch)
treebd75c7b120e3961c8536f9dc9eac97e707bb4806 /meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
parentc3433400d96ad31c01fcaecfee02b8fff14a54de (diff)
downloadpoky-6dd0f14973610925e60c89e32f56c96876f7ffb7.tar.gz
xinetd: 2.3.15 -> 2.3.15.4
This is updating from an old version from abandoned upstream repo to an actively maintained opensuse fork, hence all the changes and cleanups. License-Update: added suse copyrights (From OE-Core rev: b89c53f0ae7c4d8afdad153ad84e376e17bdb8ab) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb')
-rw-r--r--meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb b/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
new file mode 100644
index 0000000000..4f0f9531a1
--- /dev/null
+++ b/meta/recipes-extended/xinetd/xinetd_2.3.15.4.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
3
4# xinetd is a BSD-like license
5# Apple and Gentoo say BSD here.
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
8
9UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
10
11SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \
12 file://xinetd.init \
13 file://xinetd.default \
14 file://xinetd.service \
15 "
16
17SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
18
19S = "${WORKDIR}/git"
20
21inherit autotools update-rc.d systemd pkgconfig
22
23SYSTEMD_SERVICE_${PN} = "xinetd.service"
24
25INITSCRIPT_NAME = "xinetd"
26INITSCRIPT_PARAMS = "defaults"
27
28PACKAGECONFIG ??= "tcp-wrappers"
29PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
30
31CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"
32
33do_install_append() {
34 install -d "${D}${sysconfdir}/init.d"
35 install -d "${D}${sysconfdir}/default"
36 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
37 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
38
39 # Install systemd unit files
40 install -d ${D}${systemd_unitdir}/system
41 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system
42 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
43 -e 's,@SBINDIR@,${sbindir},g' \
44 ${D}${systemd_unitdir}/system/xinetd.service
45}
46
47RDEPENDS_${PN} += "perl"