summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/which/which_2.20.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-09-01 12:56:24 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:50 +0100
commit3f7f13da8ce45b73be7954b47c5e7f427264da59 (patch)
treeddeafced870119f6e28360eeddfc77adf921d90e /meta/recipes-extended/which/which_2.20.bb
parentc4ecd356d17e243655dd580b0636be1fe6ad4e77 (diff)
downloadpoky-3f7f13da8ce45b73be7954b47c5e7f427264da59.tar.gz
which (GPLv3): inherit update-alternatives to handle install priority
inherit the update-alternatives class to handle install priority issue, which is recommended by poky. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-extended/which/which_2.20.bb')
-rw-r--r--meta/recipes-extended/which/which_2.20.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/meta/recipes-extended/which/which_2.20.bb b/meta/recipes-extended/which/which_2.20.bb
index b7730de3b3..6efb24fcd8 100644
--- a/meta/recipes-extended/which/which_2.20.bb
+++ b/meta/recipes-extended/which/which_2.20.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
6HOMEPAGE = "http://ftp.gnu.org/gnu/which/" 6HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
7DEPENDS = "cwautomacros-native" 7DEPENDS = "cwautomacros-native"
8 8
9inherit autotools 9inherit autotools update-alternatives
10 10
11PR = "r0" 11PR = "r1"
12 12
13SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \ 13SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
14 file://remove-declaration.patch" 14 file://remove-declaration.patch"
@@ -22,14 +22,6 @@ do_install() {
22 mv ${D}${bindir}/which ${D}${bindir}/which.${PN} 22 mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
23} 23}
24 24
25pkg_postinst_${PN} () { 25ALTERNATIVE_NAME = "which"
26 if [ "${PN}" = "${BPN}" ] ; then 26ALTERNATIVE_PATH = "which.${PN}"
27 update-alternatives --install ${bindir}/which which which.${PN} 100 27ALTERNATIVE_PRIORITY = "100"
28 fi
29}
30
31pkg_prerm_${PN} () {
32 if [ "${PN}" = "${BPN}" ] ; then
33 update-alternatives --remove which which.${PN}
34 fi
35}