summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/which/which_2.18.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-extended/which/which_2.18.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/which/which_2.18.bb')
-rw-r--r--meta/recipes-extended/which/which_2.18.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/which/which_2.18.bb b/meta/recipes-extended/which/which_2.18.bb
new file mode 100644
index 0000000000..b177949788
--- /dev/null
+++ b/meta/recipes-extended/which/which_2.18.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Which is a utility that prints out the full path of the \
2executables that bash(1) would execute when the passed \
3program names would have been entered on the shell prompt. \
4It does this by using the exact same algorithm as bash."
5HOMEPAGE = "http://www.xs4all.nl/~carlo17/which/"
6BUGTRACKER = "n/a"
7
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
10
11PR = "r0"
12
13SRC_URI = "http://www.xs4all.nl/~carlo17/which/which-${PV}.tar.gz \
14 file://fix_name_conflict_group_member.patch"
15
16DEPENDS = "cwautomacros-native"
17
18inherit autotools
19
20do_configure_prepend() {
21 OLD="@ACLOCAL_CWFLAGS@"
22 NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4"
23 sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}`
24}
25do_install_append() {
26 mv ${D}/${bindir}/which ${D}/${bindir}/which.${PN}
27}
28
29pkg_postinst_${PN}() {
30 if [ "${PN}" = "${BPN}" ] ; then
31 update-alternatives --install ${bindir}/which which which.${PN} 100
32 fi
33}
34
35pkg_prerm_${PN}() {
36 if [ "${PN}" = "${BPN}" ] ; then
37 update-alternatives --remove which which.${PN}
38 fi
39}
40